aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/config/ltq-dsl-app/patches
diff options
context:
space:
mode:
authorMirko Vogt <mirko@openwrt.org>2012-12-03 12:46:57 +0000
committerMirko Vogt <mirko@openwrt.org>2012-12-03 12:46:57 +0000
commitf456e95dddf72f986d4935bf0fef4b11534e46c1 (patch)
treed18e63dccce433c96c249a5c89fabe7256acd0ad /package/network/config/ltq-dsl-app/patches
parent4a0f91482dd78e0c6a04dd8405c33d7510e1ef97 (diff)
downloadmaster-187ad058-f456e95dddf72f986d4935bf0fef4b11534e46c1.tar.gz
master-187ad058-f456e95dddf72f986d4935bf0fef4b11534e46c1.tar.bz2
master-187ad058-f456e95dddf72f986d4935bf0fef4b11534e46c1.zip
Make ltq-dsl-app compile with an eglibc-based toolchain
Signed-Off-By: Frank Meerkötter <frank@meerkoetter.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@34468 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/network/config/ltq-dsl-app/patches')
-rw-r--r--package/network/config/ltq-dsl-app/patches/010-eglibc_compile_fix.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/package/network/config/ltq-dsl-app/patches/010-eglibc_compile_fix.patch b/package/network/config/ltq-dsl-app/patches/010-eglibc_compile_fix.patch
new file mode 100644
index 0000000000..268f868e07
--- /dev/null
+++ b/package/network/config/ltq-dsl-app/patches/010-eglibc_compile_fix.patch
@@ -0,0 +1,23 @@
+--- a/configure.in
++++ b/configure.in
+@@ -29,6 +29,8 @@ AC_C_VOLATILE
+ #AC_FUNC_STRTOD
+ #AC_CHECK_FUNCS([ftime gethostbyname gettimeofday localtime_r memset select socket strchr strerror strstr strtoull])
+
++AC_SEARCH_LIBS([clock_gettime],[rt])
++
+ #
+ # save the configure arguments
+ #
+--- a/src/dsl_cpe_linux.h
++++ b/src/dsl_cpe_linux.h
+@@ -45,7 +45,8 @@
+ #include <arpa/inet.h>
+ #include <sys/socket.h> /* socket */
+ #include <sys/sem.h> /* semget */
+-#include <semaphore.h> /* sem_t */
++#include <semaphore.h> /* sem_t */
++#include <limits.h>
+
+ #ifdef DSL_DEBUG_TOOL_INTERFACE
+ #include <sys/socket.h>