aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/config/gre
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2014-08-05 09:57:55 +0000
committerSteven Barth <steven@midlink.org>2014-08-05 09:57:55 +0000
commit658db62b2987e32696927917f158a1b8ce47b7eb (patch)
tree43b5ba852edf9bcaf8a6c615bf49fece55103279 /package/network/config/gre
parent972a7d22d96000df460de266a4afdd83f49ee740 (diff)
downloadmaster-187ad058-658db62b2987e32696927917f158a1b8ce47b7eb.tar.gz
master-187ad058-658db62b2987e32696927917f158a1b8ce47b7eb.tar.bz2
master-187ad058-658db62b2987e32696927917f158a1b8ce47b7eb.zip
gre: Change hostdependcy to remote endpoint tunnel address
Depend on the GRE tunnel peeraddr to trigger setup of the tunnel interface. Addresses the issue reported in https://lists.openwrt.org/pipermail/openwrt-devel/2014-August/027201.html Signed-off-by: Hans Dedecker <dedeckeh@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@41998 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/network/config/gre')
-rw-r--r--package/network/config/gre/Makefile2
-rwxr-xr-xpackage/network/config/gre/files/gre.sh4
2 files changed, 3 insertions, 3 deletions
diff --git a/package/network/config/gre/Makefile b/package/network/config/gre/Makefile
index efca4643d5..9f5135e5a5 100644
--- a/package/network/config/gre/Makefile
+++ b/package/network/config/gre/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=gre
PKG_VERSION:=1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
include $(INCLUDE_DIR)/package.mk
diff --git a/package/network/config/gre/files/gre.sh b/package/network/config/gre/files/gre.sh
index 38c0fc4841..1728b01fcc 100755
--- a/package/network/config/gre/files/gre.sh
+++ b/package/network/config/gre/files/gre.sh
@@ -51,7 +51,7 @@ gre_setup() {
exit
}
- ( proto_add_host_dependency "$cfg" "0.0.0.0" "$tunlink" )
+ ( proto_add_host_dependency "$cfg" "$peeraddr" "$tunlink" )
[ -z "$ipaddr" ] && {
local wanif="$tunlink"
@@ -108,7 +108,7 @@ grev6_setup() {
exit
}
- ( proto_add_host_dependency "$cfg" "::" "$tunlink" )
+ ( proto_add_host_dependency "$cfg" "$peer6addr" "$tunlink" )
[ -z "$ip6addr" ] && {
local wanif="$tunlink"