aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/config/firewall/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2013-06-04 12:21:44 +0000
committerJo-Philipp Wich <jow@openwrt.org>2013-06-04 12:21:44 +0000
commit484c42a9349591991a1ec87dd265d817fcc89645 (patch)
tree00a01a7c347f94ee2e403d6460b118af13435769 /package/network/config/firewall/Makefile
parent64b5929539344c5b9741155c0f9454374eac1e89 (diff)
downloadmaster-187ad058-484c42a9349591991a1ec87dd265d817fcc89645.tar.gz
master-187ad058-484c42a9349591991a1ec87dd265d817fcc89645.tar.bz2
master-187ad058-484c42a9349591991a1ec87dd265d817fcc89645.zip
Drop legacy firewall package
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36837 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/network/config/firewall/Makefile')
-rw-r--r--package/network/config/firewall/Makefile58
1 files changed, 0 insertions, 58 deletions
diff --git a/package/network/config/firewall/Makefile b/package/network/config/firewall/Makefile
deleted file mode 100644
index b7e7bba4a4..0000000000
--- a/package/network/config/firewall/Makefile
+++ /dev/null
@@ -1,58 +0,0 @@
-#
-# Copyright (C) 2008-2013 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=firewall
-
-PKG_VERSION:=2
-PKG_RELEASE:=60
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/firewall
- SECTION:=net
- CATEGORY:=Base system
- URL:=http://openwrt.org/
- TITLE:=OpenWrt firewall
- MAINTAINER:=Jo-Philipp Wich <xm@subsignal.org>
- DEPENDS:=+iptables +kmod-ipt-conntrack +kmod-ipt-nat
- PKGARCH:=all
-endef
-
-define Package/firewall/description
- UCI based firewall for OpenWrt
-endef
-
-define Build/Compile
- true
-endef
-
-define Package/firewall/conffiles
-/etc/config/firewall
-/etc/firewall.user
-endef
-
-define Package/firewall/install
- $(INSTALL_DIR) $(1)/lib/firewall
- $(INSTALL_DATA) ./files/lib/*.sh $(1)/lib/firewall
- $(INSTALL_DIR) $(1)/sbin
- $(INSTALL_BIN) ./files/bin/fw $(1)/sbin
- $(INSTALL_DIR) $(1)/etc/config
- $(INSTALL_DATA) ./files/firewall.config $(1)/etc/config/firewall
- $(INSTALL_DIR) $(1)/etc/init.d/
- $(INSTALL_BIN) ./files/firewall.init $(1)/etc/init.d/firewall
- $(INSTALL_DIR) $(1)/etc/hotplug.d/iface
- $(INSTALL_DATA) ./files/firewall.hotplug $(1)/etc/hotplug.d/iface/20-firewall
- $(INSTALL_DIR) $(1)/etc/hotplug.d/firewall
- $(INSTALL_DATA) ./files/reflection.hotplug $(1)/etc/hotplug.d/firewall/10-nat-reflection
- $(INSTALL_DIR) $(1)/etc
- $(INSTALL_DATA) ./files/firewall.user $(1)/etc
- $(INSTALL_DIR) $(1)/lib/upgrade/keep.d
- $(INSTALL_DATA) ./files/firewall.upgrade $(1)/lib/upgrade/keep.d/firewall
-endef
-
-$(eval $(call BuildPackage,firewall))