aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/config/firewall/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2013-06-06 14:02:29 +0000
committerJo-Philipp Wich <jow@openwrt.org>2013-06-06 14:02:29 +0000
commit36e8f9b769eb445f7e19a97267007508e547529b (patch)
tree97498855ef39d0ae3a9c22fa9a2c9acfab3268ed /package/network/config/firewall/Makefile
parentdb43350712af21e33c03198ccd49fa8bbb3db741 (diff)
downloadmaster-187ad058-36e8f9b769eb445f7e19a97267007508e547529b.tar.gz
master-187ad058-36e8f9b769eb445f7e19a97267007508e547529b.tar.bz2
master-187ad058-36e8f9b769eb445f7e19a97267007508e547529b.zip
firewall: copy libext*.a from staging dir and drop kernel.mk includes, solves problem with colliding CONFIG_IPV6 symbols
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36868 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/network/config/firewall/Makefile')
-rw-r--r--package/network/config/firewall/Makefile5
1 files changed, 1 insertions, 4 deletions
diff --git a/package/network/config/firewall/Makefile b/package/network/config/firewall/Makefile
index a54ffc1359..9c05e34bed 100644
--- a/package/network/config/firewall/Makefile
+++ b/package/network/config/firewall/Makefile
@@ -20,7 +20,6 @@ PKG_MAINTAINER:=Jo-Philipp Wich <jow@openwrt.org>
include $(INCLUDE_DIR)/package.mk
-include $(INCLUDE_DIR)/kernel.mk
include $(INCLUDE_DIR)/cmake.mk
define Package/firewall
@@ -40,9 +39,7 @@ define Package/firewall/conffiles
endef
define Build/Configure
- $(foreach file,$(lastword $(wildcard $(KERNEL_BUILD_DIR)/iptables-*/extensions/libext.a)),$(CP) $(file) $(PKG_BUILD_DIR)/libext.a)
- $(foreach file,$(lastword $(wildcard $(KERNEL_BUILD_DIR)/iptables-*/extensions/libext4.a)),$(CP) $(file) $(PKG_BUILD_DIR)/libext4.a)
- $(foreach file,$(lastword $(wildcard $(KERNEL_BUILD_DIR)/iptables-*/extensions/libext6.a)),$(CP) $(file) $(PKG_BUILD_DIR)/libext6.a)
+ $(foreach file,$(wildcard $(STAGING_DIR)/usr/lib/iptables/libext*.a),$(CP) $(file) $(PKG_BUILD_DIR)/$(notdir $(file));)
$(call Build/Configure/Default)
endef