aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/config/firewall/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-05-26 11:11:48 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-05-26 11:11:48 +0000
commit1b04c81ab8a0fd8090fe5733a7a0b879c2014d48 (patch)
tree148d6103a3387782c9ceb304e2df28dd684c6540 /package/network/config/firewall/Makefile
parent331deccdf529624f9b9a8c357086faf18b784c00 (diff)
downloadmaster-187ad058-1b04c81ab8a0fd8090fe5733a7a0b879c2014d48.tar.gz
master-187ad058-1b04c81ab8a0fd8090fe5733a7a0b879c2014d48.tar.bz2
master-187ad058-1b04c81ab8a0fd8090fe5733a7a0b879c2014d48.zip
firewall: link iptables extensions dynamically
Use shared libipt{,4,6}ext.so libraries instead of statically linking the userspace matches into the fw3 executable. As a side effect the match initialization is extremely simplified compared to the weak function pointer juggling performed before. This also fixes the initialization of the multiport match. Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45764 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/network/config/firewall/Makefile')
-rw-r--r--package/network/config/firewall/Makefile9
1 files changed, 2 insertions, 7 deletions
diff --git a/package/network/config/firewall/Makefile b/package/network/config/firewall/Makefile
index 315720d93c..b4294f2e93 100644
--- a/package/network/config/firewall/Makefile
+++ b/package/network/config/firewall/Makefile
@@ -8,13 +8,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=firewall
-PKG_VERSION:=2015-02-26
+PKG_VERSION:=2015-05-26
PKG_RELEASE:=$(PKG_SOURCE_VERSION)
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=git://nbd.name/firewall3.git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=165029cb8c0f1545628f44143aec965e64cef021
+PKG_SOURCE_VERSION:=980b7859bbd1db1e5e46422fccccbce38f9809ab
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
PKG_MAINTAINER:=Jo-Philipp Wich <jow@openwrt.org>
PKG_LICENSE:=ISC
@@ -39,11 +39,6 @@ define Package/firewall/conffiles
/etc/firewall.user
endef
-define Build/Configure
- $(foreach file,$(wildcard $(STAGING_DIR)/usr/lib/iptables/libext*.a),$(CP) $(file) $(PKG_BUILD_DIR)/$(notdir $(file));)
- $(call Build/Configure/Default)
-endef
-
TARGET_CFLAGS += -ffunction-sections -fdata-sections
TARGET_LDFLAGS += -Wl,--gc-sections
CMAKE_OPTIONS += $(if $(CONFIG_IPV6),,-DDISABLE_IPV6=1)