aboutsummaryrefslogtreecommitdiffstats
path: root/package/mac80211/patches/020-disable_tty_set_termios.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-12-06 14:11:09 +0000
committerFelix Fietkau <nbd@openwrt.org>2012-12-06 14:11:09 +0000
commitaaf2783f6cea1e9381ad8b464e5e86eac85603c6 (patch)
treecc424bf50bfdf1515e0533ff133e895cc0f373a6 /package/mac80211/patches/020-disable_tty_set_termios.patch
parentb43862ba7b196d8fcf52d1544a0484b4c835da3a (diff)
downloadmaster-187ad058-aaf2783f6cea1e9381ad8b464e5e86eac85603c6.tar.gz
master-187ad058-aaf2783f6cea1e9381ad8b464e5e86eac85603c6.tar.bz2
master-187ad058-aaf2783f6cea1e9381ad8b464e5e86eac85603c6.zip
mac80211: clean up patches, replace patching config.mk with a generated sed expression
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@34531 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/mac80211/patches/020-disable_tty_set_termios.patch')
-rw-r--r--package/mac80211/patches/020-disable_tty_set_termios.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/package/mac80211/patches/020-disable_tty_set_termios.patch b/package/mac80211/patches/020-disable_tty_set_termios.patch
new file mode 100644
index 0000000000..fc5d4d63fb
--- /dev/null
+++ b/package/mac80211/patches/020-disable_tty_set_termios.patch
@@ -0,0 +1,16 @@
+--- a/compat/compat-2.6.39.c
++++ b/compat/compat-2.6.39.c
+@@ -12,6 +12,7 @@
+ #include <linux/tty.h>
+ #include <linux/sched.h>
+
++#ifdef CONFIG_COMPAT_BLUETOOTH
+ #if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,27))
+ /*
+ * Termios Helper Methods
+@@ -111,4 +112,4 @@ int tty_set_termios(struct tty_struct *t
+ }
+ EXPORT_SYMBOL_GPL(tty_set_termios);
+ #endif /* (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,27)) */
+-
++#endif