aboutsummaryrefslogtreecommitdiffstats
path: root/package/mac80211/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-11-14 02:35:04 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-11-14 02:35:04 +0000
commit77c792c58f76b5d75e738256db2b115dfae3fe40 (patch)
treebfc8eb55dc18acee7d50845d9872baa8be2d3061 /package/mac80211/Makefile
parent7f9778ab3ce95e81bdb8855edbda05a6c2c796e3 (diff)
downloadmaster-187ad058-77c792c58f76b5d75e738256db2b115dfae3fe40.tar.gz
master-187ad058-77c792c58f76b5d75e738256db2b115dfae3fe40.tar.bz2
master-187ad058-77c792c58f76b5d75e738256db2b115dfae3fe40.zip
mac80211: update to 2009-11-13 and add some of my new performance improvement patches. fixes excessive cpu usage of hostapd in ap mode, should also fix the ath9k memleak
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18415 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/mac80211/Makefile')
-rw-r--r--package/mac80211/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/package/mac80211/Makefile b/package/mac80211/Makefile
index 13d1670a3e..e4e9b7b546 100644
--- a/package/mac80211/Makefile
+++ b/package/mac80211/Makefile
@@ -10,12 +10,12 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=mac80211
-PKG_VERSION:=2009-11-03
-PKG_RELEASE:=2
+PKG_VERSION:=2009-11-13
+PKG_RELEASE:=1
PKG_SOURCE_URL:= \
http://www.orbit-lab.org/kernel/compat-wireless-2.6/2009/11 \
http://wireless.kernel.org/download/compat-wireless-2.6
-PKG_MD5SUM:=f8434790c9552abb9c98926d7ae616fe
+PKG_MD5SUM:=920c3bcfd1b4cd6079a8f9db4afe4e4f
PKG_SOURCE:=compat-wireless-$(PKG_VERSION).tar.bz2
PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/compat-wireless-$(PKG_VERSION)
@@ -323,9 +323,10 @@ define KernelPackage/ath9k
URL:=http://linuxwireless.org/en/users/Drivers/ath9k
DEPENDS+= +kmod-ath
FILES:= \
+ $(PKG_BUILD_DIR)/drivers/net/wireless/ath/ath9k/ath9k_common.$(LINUX_KMOD_SUFFIX) \
$(PKG_BUILD_DIR)/drivers/net/wireless/ath/ath9k/ath9k_hw.$(LINUX_KMOD_SUFFIX) \
$(PKG_BUILD_DIR)/drivers/net/wireless/ath/ath9k/ath9k.$(LINUX_KMOD_SUFFIX)
- AUTOLOAD:=$(call AutoLoad,27,ath9k_hw ath9k)
+ AUTOLOAD:=$(call AutoLoad,27,ath9k_hw ath9k_common ath9k)
endef
define KernelPackage/ath9k/description