aboutsummaryrefslogtreecommitdiffstats
path: root/package/mac80211/Makefile
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2007-08-07 09:14:45 +0000
committerFlorian Fainelli <florian@openwrt.org>2007-08-07 09:14:45 +0000
commit2221b07602278a45e4e5e76f7f11d21ff34a4888 (patch)
treef8e5c71b0e95b6bf17c2ac9f2a55f3a135fc9d32 /package/mac80211/Makefile
parent806bad6e3f84be90ff38849eead351db2ed24a80 (diff)
downloadmaster-187ad058-2221b07602278a45e4e5e76f7f11d21ff34a4888.tar.gz
master-187ad058-2221b07602278a45e4e5e76f7f11d21ff34a4888.tar.bz2
master-187ad058-2221b07602278a45e4e5e76f7f11d21ff34a4888.zip
Fix the mac80211 installation, remove the in-kernel mac80211 package, thanks to Daniel Gimpelevich
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8369 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/mac80211/Makefile')
-rw-r--r--package/mac80211/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/package/mac80211/Makefile b/package/mac80211/Makefile
index c59aaa508b..a4175ec012 100644
--- a/package/mac80211/Makefile
+++ b/package/mac80211/Makefile
@@ -57,4 +57,13 @@ ifneq ($(KERNEL_PATCHVER),2.6.21)
endef
endif
+define Build/InstallDev
+ mkdir -p $(STAGING_DIR)/usr/include/mac80211
+ $(CP) $(PKG_BUILD_DIR)/mac80211/{hostapd_ioctl,ieee80211_common}.h $(STAGING_DIR)/usr/include/mac80211
+endef
+
+define Build/UninstallDev
+ rm -rf $(STAGING_DIR)/usr/include/mac80211
+endef
+
$(eval $(call KernelPackage,mac80211))