aboutsummaryrefslogtreecommitdiffstats
path: root/package/lua/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-01-31 07:18:13 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-01-31 07:18:13 +0000
commit4f4ff4b4c36961adc82012c8c53f97e5b8658184 (patch)
treeea001b7220c10e15749e224997446b40554d1bd7 /package/lua/Makefile
parent27a519cc0bfb89b0749c4da958fb31a867a4999b (diff)
downloadmaster-187ad058-4f4ff4b4c36961adc82012c8c53f97e5b8658184.tar.gz
master-187ad058-4f4ff4b4c36961adc82012c8c53f97e5b8658184.tar.bz2
master-187ad058-4f4ff4b4c36961adc82012c8c53f97e5b8658184.zip
fix lua compile with eglibc selected and utmp support disabled
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14298 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/lua/Makefile')
-rw-r--r--package/lua/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/package/lua/Makefile b/package/lua/Makefile
index aff52c3f24..eff31390af 100644
--- a/package/lua/Makefile
+++ b/package/lua/Makefile
@@ -86,6 +86,12 @@ endef
TARGET_CFLAGS += -DLUA_USE_LINUX $(FPIC)
+ifneq ($(CONFIG_USE_EGLIBC),)
+ ifeq ($(CONFIG_EGLIBC_OPTION_EGLIBC_UTMP),)
+ TARGET_CFLAGS += -DNO_GETLOGIN
+ endif
+endif
+
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) \
CC="$(TARGET_CROSS)gcc" \