aboutsummaryrefslogtreecommitdiffstats
path: root/package/linux-atm
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-01-21 02:14:50 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-01-21 02:14:50 +0000
commitd6db09f812da2dccf6214e5094ba8b8ab45ad1f6 (patch)
tree3f88e11967b39bce0c74ab7e8d541a2325fec523 /package/linux-atm
parent1e61d2ea710628c8fca3544e7f60c4f4b14d8f65 (diff)
downloadmaster-187ad058-d6db09f812da2dccf6214e5094ba8b8ab45ad1f6.tar.gz
master-187ad058-d6db09f812da2dccf6214e5094ba8b8ab45ad1f6.tar.bz2
master-187ad058-d6db09f812da2dccf6214e5094ba8b8ab45ad1f6.zip
pass the CFLAGS through the environment on compile and fix a few packages
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6154 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/linux-atm')
-rw-r--r--package/linux-atm/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/package/linux-atm/Makefile b/package/linux-atm/Makefile
index 9aae0a0b0e..7691c1149a 100644
--- a/package/linux-atm/Makefile
+++ b/package/linux-atm/Makefile
@@ -51,11 +51,12 @@ define Build/Configure
touch $(PKG_BUILD_DIR)/stamp-h.in
endef
+TARGET_CFLAGS := -I$(PKG_BUILD_DIR)/src/include $(TARGET_CFLAGS)
define Build/Compile
- $(call Build/Compile/Default, \
+ $(MAKE) -C $(PKG_BUILD_DIR) \
+ $(TARGET_CONFIGURE_OPTS) \
DESTDIR="$(PKG_INSTALL_DIR)" \
- all install \
- )
+ all install
endef
define Build/InstallDev