aboutsummaryrefslogtreecommitdiffstats
path: root/package/libxml2
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-08-22 07:08:31 +0000
committerNicolas Thill <nico@openwrt.org>2005-08-22 07:08:31 +0000
commit6aed26a243f54e60ec850ff9a807270ae0e23786 (patch)
tree756b5d15ad5f737514e71df5239f243f9ff43504 /package/libxml2
parent7f00f46c2c13c6b57e672728bbde50cee266b73c (diff)
downloadmaster-187ad058-6aed26a243f54e60ec850ff9a807270ae0e23786.tar.gz
master-187ad058-6aed26a243f54e60ec850ff9a807270ae0e23786.tar.bz2
master-187ad058-6aed26a243f54e60ec850ff9a807270ae0e23786.zip
enable options required for libxslt,
remove lib searchpath in xml2-config, fix cleaning git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@1718 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/libxml2')
-rw-r--r--package/libxml2/Makefile15
1 files changed, 10 insertions, 5 deletions
diff --git a/package/libxml2/Makefile b/package/libxml2/Makefile
index a3c6e00f01..97845095ec 100644
--- a/package/libxml2/Makefile
+++ b/package/libxml2/Makefile
@@ -53,7 +53,7 @@ $(PKG_BUILD_DIR)/.configured:
--without-catalog \
--without-debug \
--without-docbook \
- --without-html \
+ --with-html \
--without-ftp \
--without-http \
--without-iconv \
@@ -72,9 +72,9 @@ $(PKG_BUILD_DIR)/.configured:
--with-tree \
--with-valid \
--with-writer \
- --without-xinclude \
- --without-xpath \
- --without-xptr \
+ --with-xinclude \
+ --with-xpath \
+ --with-xptr \
--with-zlib \
);
touch $@
@@ -102,13 +102,18 @@ $(STAGING_DIR)/usr/lib/libxml2.so: $(PKG_BUILD_DIR)/.built
cp -fpR $(PKG_INSTALL_DIR)/usr/lib/libxml2.{a,so*} $(STAGING_DIR)/usr/lib/
mkdir -p $(STAGING_DIR)/usr/lib/pkgconfig
cp -fpR $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libxml-2.0.pc $(STAGING_DIR)/usr/lib/pkgconfig/
+ $(SED) 's,-I$${includedir}/libxml2,,g' $(STAGING_DIR)/usr/bin/xml2-config
+ $(SED) 's,-I$${includedir},,g' $(STAGING_DIR)/usr/bin/xml2-config
+ $(SED) 's,-I$(STAGING_DIR)/usr/include,,g' $(STAGING_DIR)/usr/bin/xml2-config
+ $(SED) 's,-L$${libdir},,g' $(STAGING_DIR)/usr/bin/xml2-config
+ $(SED) 's,-L$(STAGING_DIR)/usr/lib,,g' $(STAGING_DIR)/usr/bin/xml2-config
touch $@
install-dev: $(STAGING_DIR)/usr/lib/libxml2.so
uninstall-dev:
rm -rf \
- $(STAGING_DIR)/usr/bin/libxml2-config \
+ $(STAGING_DIR)/usr/bin/xml2-config \
$(STAGING_DIR)/usr/include/libxml2 \
$(STAGING_DIR)/usr/lib/libxml2.{a,so*} \
$(STAGING_DIR)/usr/lib/pkgconfig/libxml-2.0.pc \