aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs
diff options
context:
space:
mode:
authorKarl Palsson <karlp@etactica.com>2016-07-07 14:52:35 +0200
committerZoltan HERPAI <wigyori@uid0.hu>2016-07-07 14:52:35 +0200
commitfacc1e8bd008f78b8ae008bb1eb6c3cd68ce5c71 (patch)
treef448aaf8936d008135911523500781c8c16c6287 /package/libs
parent7e6ca2d3175afcf259a553623171a1a7d37a38c0 (diff)
downloadmaster-187ad058-facc1e8bd008f78b8ae008bb1eb6c3cd68ce5c71.tar.gz
master-187ad058-facc1e8bd008f78b8ae008bb1eb6c3cd68ce5c71.tar.bz2
master-187ad058-facc1e8bd008f78b8ae008bb1eb6c3cd68ce5c71.zip
wolfssl: enable openssl 1.0.1 compatibility
>From wolfssl/openssl/opensslv.h, and from skimming the contents of what "--enable-stunnel" actually does, it seems that --enable-opensslextra doesn't give you the "full" openssl compatibility that you may wish for these days. Unfortuantely, while wolfssl writes the build time options into wolfssl/options.h, it doesn't include that file itself. User applications must include that directly. Signed-off-by: Karl Palsson <karlp@etactica.com>
Diffstat (limited to 'package/libs')
-rw-r--r--package/libs/cyassl/Makefile1
-rw-r--r--package/libs/cyassl/patches/300-debloat_move_SSL_set_tlsext_host_name_outside_STUNNEL.patch19
2 files changed, 1 insertions, 19 deletions
diff --git a/package/libs/cyassl/Makefile b/package/libs/cyassl/Makefile
index b6440f3a85..a2b3b5eef1 100644
--- a/package/libs/cyassl/Makefile
+++ b/package/libs/cyassl/Makefile
@@ -41,6 +41,7 @@ CONFIGURE_ARGS += \
--enable-singlethreaded \
--enable-opensslextra \
--enable-sni \
+ --enable-stunnel \
--enable-ecc \
--disable-examples
diff --git a/package/libs/cyassl/patches/300-debloat_move_SSL_set_tlsext_host_name_outside_STUNNEL.patch b/package/libs/cyassl/patches/300-debloat_move_SSL_set_tlsext_host_name_outside_STUNNEL.patch
deleted file mode 100644
index 51d89f7ece..0000000000
--- a/package/libs/cyassl/patches/300-debloat_move_SSL_set_tlsext_host_name_outside_STUNNEL.patch
+++ /dev/null
@@ -1,19 +0,0 @@
---- a/wolfssl/openssl/ssl.h
-+++ b/wolfssl/openssl/ssl.h
-@@ -402,6 +402,8 @@ typedef WOLFSSL_X509_STORE_CTX X509_STOR
- /* yassl had set the default to be 500 */
- #define SSL_get_default_timeout(ctx) 500
-
-+#define SSL_set_tlsext_host_name(x, y) wolfSSL_UseSNI(x, WOLFSSL_SNI_HOST_NAME, y, strlen(y))
-+
- /* Lighthttp compatibility */
-
- #ifdef HAVE_LIGHTY
-@@ -488,7 +490,6 @@ typedef WOLFSSL_ASN1_BIT_STRING ASN1_
- #define SSL_TLSEXT_ERR_NOACK alert_warning
- #define TLSEXT_NAMETYPE_host_name WOLFSSL_SNI_HOST_NAME
-
--#define SSL_set_tlsext_host_name wolfSSL_set_tlsext_host_name
- #define SSL_get_servername wolfSSL_get_servername
- #define SSL_set_SSL_CTX wolfSSL_set_SSL_CTX
- #define SSL_CTX_get_verify_callback wolfSSL_CTX_get_verify_callback