aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2016-05-10 22:37:00 +0000
committerLuka Perkov <luka@openwrt.org>2016-06-19 19:33:31 +0200
commit6bfbf28369dabe8f4917095e247b59e9f8d17dbf (patch)
treeeeac4930eebb0708af3cfdca0417d18bc7c95df9 /package/libs
parent949d8ed77956beca266274a72ed96fd7320283d1 (diff)
downloadmaster-187ad058-6bfbf28369dabe8f4917095e247b59e9f8d17dbf.tar.gz
master-187ad058-6bfbf28369dabe8f4917095e247b59e9f8d17dbf.tar.bz2
master-187ad058-6bfbf28369dabe8f4917095e247b59e9f8d17dbf.zip
ncurses: install pkg-config files to fix util-linux build breakage
Signed-off-by: Felix Fietkau <nbd@nbd.name> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@49348 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/libs')
-rw-r--r--package/libs/ncurses/Makefile11
1 files changed, 4 insertions, 7 deletions
diff --git a/package/libs/ncurses/Makefile b/package/libs/ncurses/Makefile
index c5b130ad2c..25b3807b29 100644
--- a/package/libs/ncurses/Makefile
+++ b/package/libs/ncurses/Makefile
@@ -49,6 +49,7 @@ CONFIGURE_ARGS += \
--enable-echo \
--enable-const \
--enable-overwrite \
+ --enable-pc-files \
--disable-rpath \
--without-ada \
--without-debug \
@@ -85,6 +86,7 @@ MAKE_FLAGS += \
BUILD_CC="$(HOSTCC)" \
HOSTCC="$(HOSTCC)" \
HOSTCCFLAGS="" \
+ PKG_CONFIG_LIBDIR=/usr/lib/pkgconfig \
libs
define Build/Install/Default
@@ -118,13 +120,8 @@ define Package/libncursesw/install
endef
define Build/InstallDev
- $(INSTALL_DIR) $(1)/usr/include
- $(CP) $(PKG_INSTALL_DIR)/usr/include/*.h $(1)/usr/include/
-
- $(INSTALL_DIR) $(1)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{ncurses,panel,menu,form}w.{a,so*} $(1)/usr/lib/
-
- $(INSTALL_DIR) $(1)/usr/bin $(2)/bin
+ $(CP) $(PKG_INSTALL_DIR)/* $(1)
+ $(INSTALL_DIR) $(2)/bin
$(CP) $(PKG_INSTALL_DIR)/usr/bin/ncursesw5-config $(2)/bin/
$(SED) 's,^\(prefix\|exec_prefix\)=.*,\1=$(STAGING_DIR)/usr,g' -e 's/$$$$INCS //g' \
$(2)/bin/ncursesw5-config