aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/ustream-ssl
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-04-01 10:42:33 +0000
committerJohn Crispin <blogic@openwrt.org>2015-04-01 10:42:33 +0000
commit2c0c097dd5d0e7c1a640ef965cd0002efd37c701 (patch)
treec7be8e9cc79a9126258b082bd6c09bae64a7aa4a /package/libs/ustream-ssl
parent0b2240f1e39163349f09351e2ae27d3f6067003c (diff)
downloadmaster-187ad058-2c0c097dd5d0e7c1a640ef965cd0002efd37c701.tar.gz
master-187ad058-2c0c097dd5d0e7c1a640ef965cd0002efd37c701.tar.bz2
master-187ad058-2c0c097dd5d0e7c1a640ef965cd0002efd37c701.zip
ustream-ssl: enable SNI when building for cyassl
Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45216 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/libs/ustream-ssl')
-rw-r--r--package/libs/ustream-ssl/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/libs/ustream-ssl/Makefile b/package/libs/ustream-ssl/Makefile
index 57777a0bbe..abe74ca4d6 100644
--- a/package/libs/ustream-ssl/Makefile
+++ b/package/libs/ustream-ssl/Makefile
@@ -53,7 +53,7 @@ endef
ifeq ($(BUILD_VARIANT),cyassl)
TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include/cyassl
- CMAKE_OPTIONS += -DCYASSL=on
+ CMAKE_OPTIONS += -DCYASSL=on -DHAVE_SNI
endif
ifeq ($(BUILD_VARIANT),polarssl)
CMAKE_OPTIONS += -DPOLARSSL=on