aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/openssl/Makefile
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2013-04-05 12:36:09 +0000
committerFlorian Fainelli <florian@openwrt.org>2013-04-05 12:36:09 +0000
commit221ef39aabf390285cd5af0b72b02e020832f9ff (patch)
treee397382771e693fe632cceabc0fdcd9491b5fde4 /package/libs/openssl/Makefile
parent72fa8af64d66335e3905c6398cf7e2ecd631b6e6 (diff)
downloadmaster-187ad058-221ef39aabf390285cd5af0b72b02e020832f9ff.tar.gz
master-187ad058-221ef39aabf390285cd5af0b72b02e020832f9ff.tar.bz2
master-187ad058-221ef39aabf390285cd5af0b72b02e020832f9ff.zip
openssl: Pass in any TARGET_ASFLAGS
Packages not picking up the regular TARGET_AS need their openwrt Makefiles tweaked. For a basic build, that's just openssl. This depends on patch 1/5. Signed-off-by: Jay Carlson <nop@nop.com> Signed-off-by: Florian Fainelli <florian@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36201 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/libs/openssl/Makefile')
-rw-r--r--package/libs/openssl/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/package/libs/openssl/Makefile b/package/libs/openssl/Makefile
index a8b32570ff..049aad44a8 100644
--- a/package/libs/openssl/Makefile
+++ b/package/libs/openssl/Makefile
@@ -124,6 +124,7 @@ define Build/Compile
depend
$(_SINGLE)$(MAKE) -C $(PKG_BUILD_DIR) \
CC="$(TARGET_CC)" \
+ ASFLAGS="$(TARGET_ASFLAGS) -c" \
AR="$(TARGET_CROSS)ar r" \
RANLIB="$(TARGET_CROSS)ranlib" \
OPENWRT_OPTIMIZATION_FLAGS="$(TARGET_CFLAGS)" \
@@ -131,6 +132,7 @@ define Build/Compile
all
$(MAKE) -C $(PKG_BUILD_DIR) \
CC="$(TARGET_CC)" \
+ ASFLAGS="$(TARGET_ASFLAGS) -c" \
AR="$(TARGET_CROSS)ar r" \
RANLIB="$(TARGET_CROSS)ranlib" \
OPENWRT_OPTIMIZATION_FLAGS="$(TARGET_CFLAGS)" \