aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/openssl/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-10-20 11:19:53 +0000
committerJohn Crispin <blogic@openwrt.org>2014-10-20 11:19:53 +0000
commit058c79e407f22754d5f9b2eeb9c6e19ba40126a3 (patch)
tree305c1b0f0068f20aa5ab2ca7885cfdd8dc090cad /package/libs/openssl/Makefile
parentf16cd1a9e59edc40d6eaa738fd4bd4d1b4a16b65 (diff)
downloadmaster-187ad058-058c79e407f22754d5f9b2eeb9c6e19ba40126a3.tar.gz
master-187ad058-058c79e407f22754d5f9b2eeb9c6e19ba40126a3.tar.bz2
master-187ad058-058c79e407f22754d5f9b2eeb9c6e19ba40126a3.zip
openssl: host build fails when ccache is enabled
Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43002 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/libs/openssl/Makefile')
-rw-r--r--package/libs/openssl/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/package/libs/openssl/Makefile b/package/libs/openssl/Makefile
index 8ffd7f5fed..b51808bb26 100644
--- a/package/libs/openssl/Makefile
+++ b/package/libs/openssl/Makefile
@@ -28,6 +28,11 @@ PKG_CONFIG_DEPENDS:=CONFIG_OPENSSL_ENGINE_CRYPTO CONFIG_OPENSSL_ENGINE_DIGEST \
include $(INCLUDE_DIR)/package.mk
+ifneq ($(CONFIG_CCACHE),)
+HOSTCC=$(HOSTCC_NOCACHE)
+HOSTCXX=$(HOSTCXX_NOCACHE)
+endif
+
define Package/openssl/Default
TITLE:=Open source SSL toolkit
URL:=http://www.openssl.org/