aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/ncurses
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-04-23 11:06:15 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-04-23 11:06:15 +0000
commit912768cf9d2b336edfb0a72f79c38738a1591ba1 (patch)
tree223f63f7117c30cd5315d187294cbb0b01dc2a15 /package/libs/ncurses
parent6ce964642df69e538d520e82171ed12e5c1ad417 (diff)
downloadmaster-187ad058-912768cf9d2b336edfb0a72f79c38738a1591ba1.tar.gz
master-187ad058-912768cf9d2b336edfb0a72f79c38738a1591ba1.tar.bz2
master-187ad058-912768cf9d2b336edfb0a72f79c38738a1591ba1.zip
Revert "ncurses: cleanup InstallDev"
This reverts r43204. The symlinks are faulty, as they point to a temporary staging dir Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45569 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/libs/ncurses')
-rw-r--r--package/libs/ncurses/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/libs/ncurses/Makefile b/package/libs/ncurses/Makefile
index 3e087f9497..13c7962dca 100644
--- a/package/libs/ncurses/Makefile
+++ b/package/libs/ncurses/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2014 OpenWrt.org
+# Copyright (C) 2006-2013 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -147,7 +147,7 @@ define Build/InstallDev
$(CP) $(PKG_INSTALL_DIR)/usr/bin/ncursesw5-config $(2)/bin/
$(SED) 's,^\(prefix\|exec_prefix\)=.*,\1=$(STAGING_DIR)/usr,g' -e 's/$$$$INCS //g' \
$(2)/bin/ncursesw5-config
- $(LN) $(2)/bin/ncursesw5-config $(1)/usr/bin/ncursesw5-config
+ ln -sf $(STAGING_DIR)/host/bin/ncursesw5-config $(1)/usr/bin/ncursesw5-config
endef
else
define Build/InstallDev
@@ -161,7 +161,7 @@ define Build/InstallDev
$(CP) $(PKG_INSTALL_DIR)/usr/bin/ncurses5-config $(2)/bin/
$(SED) 's,^\(prefix\|exec_prefix\)=.*,\1=$(STAGING_DIR)/usr,g' \
$(2)/bin/ncurses5-config
- $(LN) $(2)/bin/ncurses5-config $(1)/usr/bin/ncurses5-config
+ ln -sf $(STAGING_DIR)/host/bin/ncurses5-config $(1)/usr/bin/ncurses5-config
endef
endif