aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/lzo/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-11-23 20:10:02 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-11-23 20:10:02 +0000
commit49c9b2856216c41730be057c7bd4afe0e42b1a99 (patch)
tree013632cbf7cbdf9a6ccc5639a40c21d013c5e903 /package/libs/lzo/Makefile
parent4efbc8d3f509ccb67d05394c682883bb8deb5fe2 (diff)
downloadmaster-187ad058-49c9b2856216c41730be057c7bd4afe0e42b1a99.tar.gz
master-187ad058-49c9b2856216c41730be057c7bd4afe0e42b1a99.tar.bz2
master-187ad058-49c9b2856216c41730be057c7bd4afe0e42b1a99.zip
lzo: disable unaligned access for everything except x86
Fixes issues on ARM Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43349 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/libs/lzo/Makefile')
-rw-r--r--package/libs/lzo/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/libs/lzo/Makefile b/package/libs/lzo/Makefile
index b2bab05f3e..6a88a6f384 100644
--- a/package/libs/lzo/Makefile
+++ b/package/libs/lzo/Makefile
@@ -45,6 +45,10 @@ endef
TARGET_CFLAGS += $(FPIC)
MAKE_FLAGS += CFLAGS_O="$(TARGET_CFLAGS)"
+ifeq ($(CONFIG_i386)$(CONFIG_x86_64),)
+ TARGET_CFLAGS += -DLZO_CFG_NO_UNALIGNED=1
+endif
+
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/include/lzo $(1)/usr/include/