aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/libreadline
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2015-04-01 15:11:32 +0000
committerNicolas Thill <nico@openwrt.org>2015-04-01 15:11:32 +0000
commit773e8200874d9c7582996d89805f897e1f7447d3 (patch)
tree29ad2e6199a6192441f220e0d72965571d5c6e9d /package/libs/libreadline
parent2410732c218abe11d23cbc91fd76ce4e882aa8d7 (diff)
downloadmaster-187ad058-773e8200874d9c7582996d89805f897e1f7447d3.tar.gz
master-187ad058-773e8200874d9c7582996d89805f897e1f7447d3.tar.bz2
master-187ad058-773e8200874d9c7582996d89805f897e1f7447d3.zip
libreadline: cleanup Makefile, fix shlib perms
Signed-off-by: Nicolas Thill <nico@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45223 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/libs/libreadline')
-rw-r--r--package/libs/libreadline/Makefile29
-rw-r--r--package/libs/libreadline/patches/001-install_perm.patch11
2 files changed, 24 insertions, 16 deletions
diff --git a/package/libs/libreadline/Makefile b/package/libs/libreadline/Makefile
index a9e6a22163..21c8b21649 100644
--- a/package/libs/libreadline/Makefile
+++ b/package/libs/libreadline/Makefile
@@ -19,6 +19,8 @@ PKG_LICENSE:=GPL-3.0
PKG_LICENSE_FILES:=COPYING
PKG_BUILD_PARALLEL:=1
+PKG_FIXUP:=autoreconf
+PKG_INSTALL:=1
include $(INCLUDE_DIR)/package.mk
@@ -38,27 +40,22 @@ define Package/libreadline/description
history expansion on previous commands.
endef
-define Build/Configure
- $(CP) $(SCRIPT_DIR)/config.guess $(SCRIPT_DIR)/config.sub $(PKG_BUILD_DIR)/support/
- $(call Build/Configure/Default, \
- --enable-shared \
- --enable-static \
- --without-curses \
- bash_cv_wcwidth_broken=no \
- bash_cv_func_sigsetjmp=yes \
- )
-endef
+# prevent "autoreconf" from removing "aclocal.m4"
+PKG_REMOVE_FILES:=
+
+CONFIGURE_ARGS += \
+ --enable-shared \
+ --enable-static \
+ --with-curses \
+
+CONFIGURE_VARS += \
+ bash_cv_wcwidth_broken=no \
+ bash_cv_func_sigsetjmp=yes \
TARGET_CPPFLAGS:=-I. -I.. $(TARGET_CPPFLAGS)
TARGET_CFLAGS += $(FPIC)
-define Build/Compile
- $(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
- DESTDIR="$(PKG_INSTALL_DIR)" \
- all install
-endef
-
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include
$(CP) $(PKG_INSTALL_DIR)/usr/include/readline $(1)/usr/include/
diff --git a/package/libs/libreadline/patches/001-install_perm.patch b/package/libs/libreadline/patches/001-install_perm.patch
new file mode 100644
index 0000000000..951ff73e5b
--- /dev/null
+++ b/package/libs/libreadline/patches/001-install_perm.patch
@@ -0,0 +1,11 @@
+--- a/support/shlib-install
++++ b/support/shlib-install
+@@ -73,7 +73,7 @@ fi
+ case "$host_os" in
+ hpux*|darwin*|macosx*|linux*|solaris2*)
+ if [ -z "$uninstall" ]; then
+- chmod 555 ${INSTALLDIR}/${LIBNAME}
++ chmod +x ${INSTALLDIR}/${LIBNAME}
+ fi ;;
+ cygwin*|mingw*)
+ IMPLIBNAME=`echo ${LIBNAME} \