aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/libconfig
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-07-26 10:02:51 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-07-26 10:02:51 +0000
commit10bcb242857e8442ef777e8168485c118fc79eea (patch)
treed8b7fc7c96c7686bf690e13455848ef571470ebf /package/libs/libconfig
parent9224a7933f709a7fa5f87d6ed043857fa9d25498 (diff)
downloadmaster-187ad058-10bcb242857e8442ef777e8168485c118fc79eea.tar.gz
master-187ad058-10bcb242857e8442ef777e8168485c118fc79eea.tar.bz2
master-187ad058-10bcb242857e8442ef777e8168485c118fc79eea.zip
libconfig: add from /packages, update to latest version, add myself as maintainer
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37552 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/libs/libconfig')
-rw-r--r--package/libs/libconfig/Makefile58
1 files changed, 58 insertions, 0 deletions
diff --git a/package/libs/libconfig/Makefile b/package/libs/libconfig/Makefile
new file mode 100644
index 0000000000..5ade648fe3
--- /dev/null
+++ b/package/libs/libconfig/Makefile
@@ -0,0 +1,58 @@
+#
+# Copyright (C) 2008-2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libconfig
+PKG_VERSION:=1.4.9
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://www.hyperrealm.com/libconfig
+PKG_MD5SUM:=b6ee0ce2b3ef844bad7cac2803a90634
+
+PKG_FIXUP:=autoreconf
+PKG_INSTALL:=1
+
+PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/libconfig
+ SECTION:=libs
+ CATEGORY:=Libraries
+ TITLE:=Configuration File Library
+ URL:=http://www.hyperrealm.com/libconfig/
+endef
+
+define Package/libconfig/description
+ Libconfig is a simple library for manipulating structured configuration
+ files. This file format is more compact and more readable than XML. And
+ unlike XML, it is type-aware, so it is not necessary to do string
+ parsing in application code.
+
+ Libconfig is very compact -- just 38K for the stripped C shared
+ library (less than one-fourth the size of the expat XML parser library)
+ and 66K for the stripped C++ shared library. This makes it well-suited
+ for memory-constrained systems like handheld devices.
+endef
+
+CONFIGURE_ARGS += \
+ --enable-shared \
+ --disable-static \
+ --disable-cxx
+
+define Build/InstallDev
+ $(CP) $(PKG_INSTALL_DIR)/* $(1)/
+endef
+
+define Package/libconfig/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libconfig.so* $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,libconfig))