aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/libbsd/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-10-08 11:24:12 +0000
committerFelix Fietkau <nbd@openwrt.org>2012-10-08 11:24:12 +0000
commita17a510a62530af270844247c985073688d4d7cb (patch)
tree5155ea7bc428f0af268c4c63435d0696d18b124d /package/libs/libbsd/Makefile
parent350022b54ac1dee0e1a99ef8d6391ed60ded584d (diff)
downloadmaster-187ad058-a17a510a62530af270844247c985073688d4d7cb.tar.gz
master-187ad058-a17a510a62530af270844247c985073688d4d7cb.tar.bz2
master-187ad058-a17a510a62530af270844247c985073688d4d7cb.zip
move library packages to package/libs/
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33657 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/libs/libbsd/Makefile')
-rw-r--r--package/libs/libbsd/Makefile54
1 files changed, 54 insertions, 0 deletions
diff --git a/package/libs/libbsd/Makefile b/package/libs/libbsd/Makefile
new file mode 100644
index 0000000000..4fef04a233
--- /dev/null
+++ b/package/libs/libbsd/Makefile
@@ -0,0 +1,54 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libbsd
+PKG_VERSION:=0.3.0
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://libbsd.freedesktop.org/releases
+#PKG_MD5SUM:=d0870f2de55d59c1c8419f36e8fac150
+
+include $(INCLUDE_DIR)/package.mk
+
+PKG_INSTALL:=1
+
+define Package/libbsd
+ SECTION:=libs
+ CATEGORY:=Libraries
+ DEPENDS:=@!USE_UCLIBC
+ TITLE:=common BSD library
+endef
+
+define Package/libbsd/description
+ This library provides useful functions commonly found on BSD systems, and lacking on others like GNU systems, thus making it easier to port projects with strong BSD origins, without needing to embed the same code over and over again on each project.
+endef
+
+define Build/InstallDev
+ $(INSTALL_DIR) \
+ $(1)/lib \
+ $(1)/usr/include
+
+ $(CP) \
+ $(PKG_INSTALL_DIR)/lib/libbsd.so* \
+ $(1)/lib/
+
+ $(CP) \
+ $(PKG_INSTALL_DIR)/usr/include/* \
+ $(1)/usr/include/
+
+ ( cd $(1)/lib ; ln -s libbsd.so.$(PKG_VERSION) libbsd.so )
+endef
+
+define Package/libbsd/install
+ $(INSTALL_DIR) \
+ $(1)/lib
+
+ $(CP) \
+ $(PKG_INSTALL_DIR)/lib/libbsd.so* \
+ $(1)/lib/
+
+ ( cd $(1)/lib ; ln -s libbsd.so.$(PKG_VERSION) libbsd.so )
+endef
+
+$(eval $(call BuildPackage,libbsd))
+