aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/cyassl
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-04-01 10:42:28 +0000
committerJohn Crispin <blogic@openwrt.org>2015-04-01 10:42:28 +0000
commit0b2240f1e39163349f09351e2ae27d3f6067003c (patch)
tree45eb71804778740b9da307fc1de7d07ef8f17d2c /package/libs/cyassl
parentf9e85a0e4f7f0c005d2d56c861bfe9aff264a720 (diff)
downloadmaster-187ad058-0b2240f1e39163349f09351e2ae27d3f6067003c.tar.gz
master-187ad058-0b2240f1e39163349f09351e2ae27d3f6067003c.tar.bz2
master-187ad058-0b2240f1e39163349f09351e2ae27d3f6067003c.zip
cyassl: add support for SSL_set_tlsext_host_name
Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45215 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/libs/cyassl')
-rw-r--r--package/libs/cyassl/Makefile2
-rw-r--r--package/libs/cyassl/patches/300-SSL_set_tlsext_host_name.patch10
2 files changed, 12 insertions, 0 deletions
diff --git a/package/libs/cyassl/Makefile b/package/libs/cyassl/Makefile
index a748adbb6b..2be0198c64 100644
--- a/package/libs/cyassl/Makefile
+++ b/package/libs/cyassl/Makefile
@@ -40,6 +40,8 @@ TARGET_CFLAGS += $(FPIC)
CONFIGURE_ARGS += \
--without-zlib \
--enable-singlethreaded \
+ --enable-opensslextra \
+ --enable-sni \
--disable-examples
define Build/InstallDev
diff --git a/package/libs/cyassl/patches/300-SSL_set_tlsext_host_name.patch b/package/libs/cyassl/patches/300-SSL_set_tlsext_host_name.patch
new file mode 100644
index 0000000000..d81e416180
--- /dev/null
+++ b/package/libs/cyassl/patches/300-SSL_set_tlsext_host_name.patch
@@ -0,0 +1,10 @@
+--- a/cyassl/openssl/ssl.h
++++ b/cyassl/openssl/ssl.h
+@@ -372,6 +373,7 @@
+ #define SSL_CTX_get_ex_new_index CyaSSL_CTX_get_ex_new_index
+
+
++#define SSL_set_tlsext_host_name(x, y) CyaSSL_UseSNI(x, CYASSL_SNI_HOST_NAME, y, strlen(y))
+
+ #ifdef __cplusplus
+ } /* extern "C" */