aboutsummaryrefslogtreecommitdiffstats
path: root/package/libnl-tiny/src/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-04-30 13:57:29 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-04-30 13:57:29 +0000
commit170da602da28b9401d043e068fe4192aeb064d0e (patch)
treea15d257ea63d5208cf9c790366af0d3d3eed4eec /package/libnl-tiny/src/Makefile
parentfdcbeac21e079561b07d9584392ca1a02bbe7307 (diff)
downloadmaster-187ad058-170da602da28b9401d043e068fe4192aeb064d0e.tar.gz
master-187ad058-170da602da28b9401d043e068fe4192aeb064d0e.tar.bz2
master-187ad058-170da602da28b9401d043e068fe4192aeb064d0e.zip
add libnl-tiny as a small replacement for libnl with only genl support included
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@15507 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/libnl-tiny/src/Makefile')
-rw-r--r--package/libnl-tiny/src/Makefile17
1 files changed, 17 insertions, 0 deletions
diff --git a/package/libnl-tiny/src/Makefile b/package/libnl-tiny/src/Makefile
new file mode 100644
index 0000000000..f684155ecc
--- /dev/null
+++ b/package/libnl-tiny/src/Makefile
@@ -0,0 +1,17 @@
+CC=gcc
+WFLAGS=-Wall
+CFLAGS=-O2
+INCLUDES=-Iinclude
+
+LIBNAME=libnl-tiny.so
+
+all: $(LIBNAME)
+
+%.o: %.c
+ $(CC) $(WFLAGS) -c -o $@ $(INCLUDES) $(CFLAGS) $<
+
+LIBNL_OBJ=nl.o handlers.o msg.o attr.o cache.o cache_mngt.o object.o socket.o error.o
+GENL_OBJ=genl.o genl_family.o genl_ctrl.o genl_mngt.o
+
+$(LIBNAME): $(LIBNL_OBJ) $(GENL_OBJ)
+ $(CC) -shared -o $@ $^