aboutsummaryrefslogtreecommitdiffstats
path: root/package/keynote/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-09-28 01:45:11 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-09-28 01:45:11 +0000
commitbb6c4aade1c3174895429f168d4eac7a67d312cd (patch)
treeeb4212ed9fc412f6018213aec05fae3059ed20bf /package/keynote/Makefile
parent499485004b52b5960c950922fb1dedcedd0923fa (diff)
downloadmaster-187ad058-bb6c4aade1c3174895429f168d4eac7a67d312cd.tar.gz
master-187ad058-bb6c4aade1c3174895429f168d4eac7a67d312cd.tar.bz2
master-187ad058-bb6c4aade1c3174895429f168d4eac7a67d312cd.zip
add $(STAGING_DIR) as argument to the InstallDev template and update packages accordingly - this way we can reuse InstallDev to automatically generate UninstallDev or create -dev packages
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9052 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/keynote/Makefile')
-rw-r--r--package/keynote/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/package/keynote/Makefile b/package/keynote/Makefile
index 9fe38678dd..1aea7cbc60 100644
--- a/package/keynote/Makefile
+++ b/package/keynote/Makefile
@@ -41,15 +41,15 @@ MAKE_FLAGS += \
CFLAGS="$(TARGET_CFLAGS)"
define Build/InstallDev
- mkdir -p $(STAGING_DIR)/usr/include/keynote
- $(CP) $(PKG_BUILD_DIR)/{assertion,header,keynote,signature}.h $(STAGING_DIR)/usr/include/keynote/
- mkdir -p $(STAGING_DIR)/usr/lib
- $(CP) $(PKG_BUILD_DIR)/libkeynote.a $(STAGING_DIR)/usr/lib/
+ mkdir -p $(1)/usr/include/keynote
+ $(CP) $(PKG_BUILD_DIR)/{assertion,header,keynote,signature}.h $(1)/usr/include/keynote/
+ mkdir -p $(1)/usr/lib
+ $(CP) $(PKG_BUILD_DIR)/libkeynote.a $(1)/usr/lib/
endef
define Build/UninstallDev
- rm -rf $(STAGING_DIR)/usr/include/keynote \
- $(STAGING_DIR)/usr/lib/libkeynote.a
+ rm -rf $(1)/usr/include/keynote \
+ $(1)/usr/lib/libkeynote.a
endef
define Package/keynote/install