aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-09-21 17:18:43 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-09-21 17:18:43 +0000
commite1a46cdf9346f5d0b4c04018c7dda97e224edf64 (patch)
tree5062c7ab39de87d3bf1aaf998d3e72e734000967 /package/kernel
parent8bb1952983fc3fc15455ef3761fd2298cd86a941 (diff)
downloadmaster-187ad058-e1a46cdf9346f5d0b4c04018c7dda97e224edf64.tar.gz
master-187ad058-e1a46cdf9346f5d0b4c04018c7dda97e224edf64.tar.bz2
master-187ad058-e1a46cdf9346f5d0b4c04018c7dda97e224edf64.zip
ath10k: remove API v2 firmware, it is no longer needed
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47009 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/mac80211/Makefile19
1 files changed, 0 insertions, 19 deletions
diff --git a/package/kernel/mac80211/Makefile b/package/kernel/mac80211/Makefile
index 4db7c8cd8a..f332cbd628 100644
--- a/package/kernel/mac80211/Makefile
+++ b/package/kernel/mac80211/Makefile
@@ -270,19 +270,6 @@ Atheros IEEE 802.11ac family of chipsets. For now only
PCI is supported.
endef
-define KernelPackage/ath10k/config
- if PACKAGE_kmod-ath10k
-
- config ATH10K_API2_FW
- bool "Use old AP mode firmware release (v10.1 / API v2)"
- default n
- help
- Use the ath10k firmware from the 10.1 SDK using API v2 optimized
- for access point operation if the default firmware keeps crashing.
-
- endif
-endef
-
PKG_ATH10K_LINUX_FIRMWARE_NAME:=ath10k-firmware
PKG_ATH10K_LINUX_FIRMWARE_VERSION:=b46f3e01a6c1f9150fb4612ef53611d714565842
PKG_ATH10K_LINUX_FIRMWARE_SOURCE:=$(PKG_ATH10K_LINUX_FIRMWARE_NAME)-$(PKG_ATH10K_LINUX_FIRMWARE_VERSION).tar.bz2
@@ -1867,15 +1854,9 @@ define KernelPackage/ath10k/install
$(INSTALL_DATA) \
$(PKG_BUILD_DIR)/$(PKG_ATH10K_LINUX_FIRMWARE_SUBDIR)/ath10k/QCA988X/hw2.0/board.bin \
$(1)/lib/firmware/ath10k/QCA988X/hw2.0/
-ifeq ($(CONFIG_ATH10K_API2_FW),y)
- $(INSTALL_DATA) \
- $(PKG_BUILD_DIR)/$(PKG_ATH10K_LINUX_FIRMWARE_SUBDIR)/10.1/firmware-2.bin_10.1.467.2-1 \
- $(1)/lib/firmware/ath10k/QCA988X/hw2.0/firmware-2.bin
-else
$(INSTALL_DATA) \
$(PKG_BUILD_DIR)/$(PKG_ATH10K_LINUX_FIRMWARE_SUBDIR)/10.2.4/untested/firmware-5.bin_10.2.4.70-2 \
$(1)/lib/firmware/ath10k/QCA988X/hw2.0/firmware-5.bin
-endif
endef
define KernelPackage/b43/install