aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-10-27 12:33:00 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-10-27 12:33:00 +0000
commitd440ced2ef1bdc497e75356220c78c41448a2684 (patch)
treed9c143a2c0a22446dc10599a5c59fea407e2df02 /package/kernel
parent52b8424c480075d8c40b0a30f979b315e2d372ad (diff)
downloadmaster-187ad058-d440ced2ef1bdc497e75356220c78c41448a2684.tar.gz
master-187ad058-d440ced2ef1bdc497e75356220c78c41448a2684.tar.bz2
master-187ad058-d440ced2ef1bdc497e75356220c78c41448a2684.zip
package/kernel: arc4 needs blkcipher support on 3.6
[ 78.530000] arc4: Unknown symbol blkcipher_walk_done (err 0) [ 78.530000] arc4: Unknown symbol blkcipher_walk_virt (err 0) [ 78.540000] arc4: Unknown symbol crypto_blkcipher_type (err 0) Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33965 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/modules/crypto.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/modules/crypto.mk b/package/kernel/modules/crypto.mk
index 43a7cc3431..dc21c1d53a 100644
--- a/package/kernel/modules/crypto.mk
+++ b/package/kernel/modules/crypto.mk
@@ -192,7 +192,7 @@ define KernelPackage/crypto-arc4
KCONFIG:=CONFIG_CRYPTO_ARC4
FILES:=$(LINUX_DIR)/crypto/arc4.ko
AUTOLOAD:=$(call AutoLoad,09,arc4)
- $(call AddDepends/crypto)
+ $(call AddDepends/crypto,+!LINUX_3_3:kmod-crypto-manager)
endef
$(eval $(call KernelPackage,crypto-arc4))