aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2012-10-24 13:04:54 +0000
committerFlorian Fainelli <florian@openwrt.org>2012-10-24 13:04:54 +0000
commitd059b26520fd58b55afd669a799f323620a96df6 (patch)
tree36f353f45efa5159cf51129b3359591add5aff8a /package/kernel
parent9d344ea65bb46d99a1ad5d827517ef7ce09ba8c4 (diff)
downloadmaster-187ad058-d059b26520fd58b55afd669a799f323620a96df6.tar.gz
master-187ad058-d059b26520fd58b55afd669a799f323620a96df6.tar.bz2
master-187ad058-d059b26520fd58b55afd669a799f323620a96df6.zip
[package] kernel: the camellia module name has changed in kernel 3.4
With the support for architecture optimized camellia routines, the original camellia module got renamed to camellia_generic, account for that. git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33903 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/modules/crypto.mk5
1 files changed, 4 insertions, 1 deletions
diff --git a/package/kernel/modules/crypto.mk b/package/kernel/modules/crypto.mk
index 984ccc1f9b..43a7cc3431 100644
--- a/package/kernel/modules/crypto.mk
+++ b/package/kernel/modules/crypto.mk
@@ -324,6 +324,9 @@ endef
$(eval $(call KernelPackage,crypto-sha1))
+ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.6.0)),1)
+camellia_mod_suffix=_generic
+endif
define KernelPackage/crypto-misc
TITLE:=Other CryptoAPI modules
@@ -347,7 +350,7 @@ define KernelPackage/crypto-misc
CONFIG_CRYPTO_WP512
FILES:= \
$(LINUX_DIR)/crypto/anubis.ko \
- $(LINUX_DIR)/crypto/camellia.ko \
+ $(LINUX_DIR)/crypto/camellia$(camellia_mod_suffix).ko \
$(LINUX_DIR)/crypto/cast5.ko \
$(LINUX_DIR)/crypto/cast6.ko \
$(LINUX_DIR)/crypto/fcrypt.ko \