aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2007-05-28 08:43:04 +0000
committerFlorian Fainelli <florian@openwrt.org>2007-05-28 08:43:04 +0000
commitd02c762dd1772996920081d60a1097ffe50b7d68 (patch)
tree9359711c0abccaa3de4af81147ab00554669b9a3 /package/kernel
parent780c7ce02a5d252c3a135de7aefe9ac76a5bb887 (diff)
downloadmaster-187ad058-d02c762dd1772996920081d60a1097ffe50b7d68.tar.gz
master-187ad058-d02c762dd1772996920081d60a1097ffe50b7d68.tar.bz2
master-187ad058-d02c762dd1772996920081d60a1097ffe50b7d68.zip
Fix the scx200 gpio kernel module (#1072)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7364 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/modules/i2c.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/kernel/modules/i2c.mk b/package/kernel/modules/i2c.mk
index a0b121c334..31801a6b84 100644
--- a/package/kernel/modules/i2c.mk
+++ b/package/kernel/modules/i2c.mk
@@ -47,9 +47,9 @@ define KernelPackage/i2c-scx200
DEFAULT:=y if LINUX_2_6_X86_Soekris
DEPENDS:=kmod-i2c-core kmod-i2c-algos @LINUX_2_6_X86_Soekris
SUBMENU:=$(I2CMENU)
- KCONFIG:=$(CONFIG_I2C_SCX200)
+ KCONFIG:=$(CONFIG_SCx200_I2C)
FILES:=$(LINUX_DIR)/drivers/i2c/busses/scx200_i2c.$(LINUX_KMOD_SUFFIX) \
$(LINUX_DIR)/drivers/i2c/busses/i2c-isa.$(LINUX_KMOD_SUFFIX)
- AUTOLOAD:=$(call AutoLoad,70,scx200_i2c)
+ AUTOLOAD:=$(call AutoLoad,70,i2c-isa scx200_i2c)
endef
$(eval $(call KernelPackage,i2c-scx200))