aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-05-03 21:14:56 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-05-03 21:14:56 +0000
commitbf55314c5f99f07a951d854338c7254a477f7cf1 (patch)
treeb2b021f5d931e14976f4d795096d351a89a08b6b /package/kernel
parent82b7058bc142872ccac395be779f8123b2842f97 (diff)
downloadmaster-187ad058-bf55314c5f99f07a951d854338c7254a477f7cf1.tar.gz
master-187ad058-bf55314c5f99f07a951d854338c7254a477f7cf1.tar.bz2
master-187ad058-bf55314c5f99f07a951d854338c7254a477f7cf1.zip
ath: Add config option for DFS support
This patch adds a config option to enable DFS in ath9k and ath10k drivers (with ath10k you need the AP-branch firmware). I'm not entirely sure about the regulatory compliance issues, though. As far as I understand, enabling the DFS_CERTIFIED config options implies that the device is certified for DFS. No doubt the original firmware has obtained such a certification, but not with the open source drivers. I suppose that as long as this is disabled in default builds (like ATH_USER_REGD) everything should be fine, but it would be nice to have out-of-the-box OpenWrt support for DFS. I'm also not sure whether the description of the configuration option should say something about regulatory compliance. Signed-off-by: Matti Laakso <malaakso@elisanet.fi> Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@40692 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/mac80211/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/package/kernel/mac80211/Makefile b/package/kernel/mac80211/Makefile
index 845bef8c0e..d1759fd01c 100644
--- a/package/kernel/mac80211/Makefile
+++ b/package/kernel/mac80211/Makefile
@@ -39,6 +39,7 @@ PKG_CONFIG_DEPENDS:= \
CONFIG_PACKAGE_MAC80211_DEBUGFS \
CONFIG_PACKAGE_MAC80211_MESH \
CONFIG_PACKAGE_ATH_DEBUG \
+ CONFIG_PACKAGE_ATH_DFS \
CONFIG_PACKAGE_B43_DEBUG \
CONFIG_PACKAGE_B43_PIO \
CONFIG_PACKAGE_B43_N_PHY \
@@ -510,6 +511,16 @@ define KernelPackage/ath/config
help
Say Y, if you want to debug atheros wireless drivers.
Right now only ath9k makes use of this.
+
+ config PACKAGE_ATH_DFS
+ bool "Enable DFS support"
+ help
+ Dynamic frequency selection (DFS) is required for most of the 5 GHz band
+ channels in Europe, US, and Japan.
+
+ Select this option if you want to use such channels. Only EU (ETSI) DFS
+ is supported at the moment.
+
endif
endef
@@ -1380,6 +1391,7 @@ config-$(call config_package,lib80211) += LIB80211 LIB80211_CRYPT_WEP LIB80211_C
config-$(call config_package,ath) += ATH_CARDS ATH_COMMON
config-$(CONFIG_PACKAGE_ATH_DEBUG) += ATH_DEBUG ATH10K_DEBUG
+config-$(CONFIG_PACKAGE_ATH_DFS) += ATH9K_DFS_CERTIFIED ATH10K_DFS_CERTIFIED
config-$(call config_package,ath9k) += ATH9K
config-$(call config_package,ath9k-common) += ATH9K_COMMON