aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-04-06 16:55:25 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-04-06 16:55:25 +0000
commitb794699a7a111a669bfafc5fc45ea576fb632f6a (patch)
tree3dc18a24fb4e1c15243b6934f0a451ba496ec8e0 /package/kernel
parent5eab2bb70bb25f32148889b963fb97c195eb356a (diff)
downloadmaster-187ad058-b794699a7a111a669bfafc5fc45ea576fb632f6a.tar.gz
master-187ad058-b794699a7a111a669bfafc5fc45ea576fb632f6a.tar.bz2
master-187ad058-b794699a7a111a669bfafc5fc45ea576fb632f6a.zip
package/kernel: only include i2c-of if CONFIG_OF enabled
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36227 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/modules/i2c.mk5
1 files changed, 4 insertions, 1 deletions
diff --git a/package/kernel/modules/i2c.mk b/package/kernel/modules/i2c.mk
index 5cf929de97..085570836f 100644
--- a/package/kernel/modules/i2c.mk
+++ b/package/kernel/modules/i2c.mk
@@ -22,9 +22,12 @@ endef
I2C_CORE_MODULES:= \
CONFIG_I2C:drivers/i2c/i2c-core \
- CONFIG_OF_I2C:drivers/of/of_i2c \
CONFIG_I2C_CHARDEV:drivers/i2c/i2c-dev
+ifeq (CONFIG_OF,y)
+ I2C_CORE_MODULES+=CONFIG_OF_I2C:drivers/of/of_i2c
+endif
+
define KernelPackage/i2c-core
$(call i2c_defaults,$(I2C_CORE_MODULES),51)
TITLE:=I2C support