aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2014-06-20 20:44:18 +0000
committerImre Kaloz <kaloz@openwrt.org>2014-06-20 20:44:18 +0000
commitae8972e459c7a9ed7699ef176651ff78028203b4 (patch)
tree41f98dddd8a58f7086b087e0cd0c7f2263683fc9 /package/kernel
parent10c5dff2322884a13292cdc8ce8d6fbd6103b2d9 (diff)
downloadmaster-187ad058-ae8972e459c7a9ed7699ef176651ff78028203b4.tar.gz
master-187ad058-ae8972e459c7a9ed7699ef176651ff78028203b4.tar.bz2
master-187ad058-ae8972e459c7a9ed7699ef176651ff78028203b4.zip
[kernel]: make thermal framework registered sensors also register as hwmons
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@41290 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/linux/modules/other.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 8f68bd8251..2f6f774e1f 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -855,6 +855,7 @@ define KernelPackage/thermal
CONFIG_THERMAL_GOV_FAIR_SHARE=n \
CONFIG_THERMAL_GOV_STEP_WISE=y \
CONFIG_THERMAL_GOV_USER_SPACE=n \
+ CONFIG_THERMAL_HWMON=y \
CONFIG_THERMAL_EMULATION=n
FILES:=$(LINUX_DIR)/drivers/thermal/thermal_sys.ko
AUTOLOAD:=$(call AutoProbe,thermal_sys)