aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorDaniel Dickinson <lede@daniel.thecshore.com>2016-06-25 17:52:15 +0200
committerZoltan HERPAI <wigyori@uid0.hu>2016-06-25 17:52:15 +0200
commita6e2b265d1e9c2a180e6fdb01d3094e526f83691 (patch)
treeddd94b3614526712601c229573f7cd0d3904ab99 /package/kernel
parenteffa5a628be0fb3e400dd97b6550d2d60d0260f2 (diff)
downloadmaster-187ad058-a6e2b265d1e9c2a180e6fdb01d3094e526f83691.tar.gz
master-187ad058-a6e2b265d1e9c2a180e6fdb01d3094e526f83691.tar.bz2
master-187ad058-a6e2b265d1e9c2a180e6fdb01d3094e526f83691.zip
kernel: Build it87 hardware monitor module
Add packaging of it87 hardware monitor kernel module. It is a common thermal and voltage monitor that is in many x86 (at least) devices, and is just another i2c hwmon module. Signed-off-by: Daniel Dickinson <lede@daniel.thecshore.com>
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/linux/modules/hwmon.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/hwmon.mk b/package/kernel/linux/modules/hwmon.mk
index 93d7a775a9..f7c305ddb9 100644
--- a/package/kernel/linux/modules/hwmon.mk
+++ b/package/kernel/linux/modules/hwmon.mk
@@ -93,6 +93,20 @@ endef
$(eval $(call KernelPackage,hwmon-ina2xx))
+define KernelPackage/hwmon-it87
+ TITLE:=IT87 monitoring support
+ KCONFIG:=CONFIG_SENSORS_IT87
+ FILES:=$(LINUX_DIR)/drivers/hwmon/it87.ko
+ AUTOLOAD:=$(call AutoProbe,it87)
+ $(call AddDepends/hwmon,+kmod-i2c-core +kmod-hwmon-vid +PACKAGE_kmod-thermal:kmod-thermal)
+endef
+
+define KernelPackage/hwmon-it87/description
+ Kernel module for it87 thermal and voltage monitor chip
+endef
+
+$(eval $(call KernelPackage,hwmon-it87))
+
define KernelPackage/hwmon-lm63
TITLE:=LM63/64 monitoring support
KCONFIG:=CONFIG_SENSORS_LM63