aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorAlexander Couzens <lynxis@fe80.eu>2016-06-30 23:49:59 +0200
committerZoltan HERPAI <wigyori@uid0.hu>2016-06-30 23:49:59 +0200
commita244a11be90e6cd9d66bd1dc1cc35668288c88b1 (patch)
tree3b41b32b7587c8a42a02fa9bf4187b1301e3aae3 /package/kernel
parent94c6e7edede5ad9fa4b403f4269fe09dda618821 (diff)
downloadmaster-187ad058-a244a11be90e6cd9d66bd1dc1cc35668288c88b1.tar.gz
master-187ad058-a244a11be90e6cd9d66bd1dc1cc35668288c88b1.tar.bz2
master-187ad058-a244a11be90e6cd9d66bd1dc1cc35668288c88b1.zip
kernel: add random-omap rng for omap
Kernel module for the OMAP Random Number Generator found on OMAP16xx, OMAP2/3/4/5 and AM33xx/AM43xx multimedia processors. Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/linux/modules/other.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 528d32f0b7..ef0fbce09a 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -891,6 +891,21 @@ endef
$(eval $(call KernelPackage,random-core))
+define KernelPackage/random-omap
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=Hardware Random Number Generator OMAP support
+ KCONFIG:=CONFIG_HW_RANDOM_OMAP
+ FILES:=$(LINUX_DIR)/drivers/char/hw_random/omap-rng.ko
+ DEPENDS:=@(TARGET_omap24xx||TARGET_omap) +kmod-random-core
+ AUTOLOAD:=$(call AutoProbe,random-omap)
+endef
+
+define KernelPackage/random-omap/description
+ Kernel module for the OMAP Random Number Generator
+ found on OMAP16xx, OMAP2/3/4/5 and AM33xx/AM43xx multimedia processors.
+endef
+
+$(eval $(call KernelPackage,random-omap))
define KernelPackage/thermal
SUBMENU:=$(OTHER_MENU)