aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-06-25 17:06:37 +0200
committerZoltan HERPAI <wigyori@uid0.hu>2016-06-25 17:06:37 +0200
commit768e546b34ef46d07043d8c9d45ad237661c04e4 (patch)
treed0cb1d6b85d52138d46448e49955a9ba9680efcd /package/kernel
parente8ae2da9ea0ca51bd41876f5021aa24862fc1248 (diff)
downloadmaster-187ad058-768e546b34ef46d07043d8c9d45ad237661c04e4.tar.gz
master-187ad058-768e546b34ef46d07043d8c9d45ad237661c04e4.tar.bz2
master-187ad058-768e546b34ef46d07043d8c9d45ad237661c04e4.zip
x86: remove the kvm_guest subtarget
32-bit only hardware that supports kvm is very rare. It's not worth keeping a separate subtarget for this. Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/linux/modules/virtual.mk48
1 files changed, 0 insertions, 48 deletions
diff --git a/package/kernel/linux/modules/virtual.mk b/package/kernel/linux/modules/virtual.mk
index 61a8a87609..e18c376d3e 100644
--- a/package/kernel/linux/modules/virtual.mk
+++ b/package/kernel/linux/modules/virtual.mk
@@ -7,54 +7,6 @@
VIRTUAL_MENU:=Virtualization Support
-define KernelPackage/virtio-balloon
- SUBMENU:=$(VIRTUAL_MENU)
- TITLE:=VirtIO balloon driver
- DEPENDS:=@TARGET_x86_kvm_guest
- KCONFIG:=CONFIG_VIRTIO_BALLOON
- FILES:=$(LINUX_DIR)/drivers/virtio/virtio_balloon.ko
- AUTOLOAD:=$(call AutoLoad,06,virtio-balloon)
-endef
-
-define KernelPackage/virtio-balloon/description
- Kernel module for VirtIO memory ballooning support
-endef
-
-$(eval $(call KernelPackage,virtio-balloon))
-
-
-define KernelPackage/virtio-net
- SUBMENU:=$(VIRTUAL_MENU)
- TITLE:=VirtIO network driver
- DEPENDS:=@TARGET_x86_kvm_guest
- KCONFIG:=CONFIG_VIRTIO_NET
- FILES:=$(LINUX_DIR)/drivers/net/virtio_net.ko
- AUTOLOAD:=$(call AutoLoad,50,virtio_net)
-endef
-
-define KernelPackage/virtio-net/description
- Kernel module for the VirtIO paravirtualized network device
-endef
-
-$(eval $(call KernelPackage,virtio-net))
-
-
-define KernelPackage/virtio-random
- SUBMENU:=$(VIRTUAL_MENU)
- TITLE:=VirtIO Random Number Generator support
- DEPENDS:=@TARGET_x86_kvm_guest
- KCONFIG:=CONFIG_HW_RANDOM_VIRTIO
- FILES:=$(LINUX_DIR)/drivers/char/hw_random/virtio-rng.ko
- AUTOLOAD:=$(call AutoLoad,09,virtio-rng)
-endef
-
-define KernelPackage/virtio-random/description
- Kernel module for the VirtIO Random Number Generator
-endef
-
-$(eval $(call KernelPackage,virtio-random))
-
-
define KernelPackage/xen-privcmd
SUBMENU:=$(VIRTUAL_MENU)
TITLE:=Xen private commands