aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@openwrt.org>2013-01-06 16:21:29 +0000
committerHauke Mehrtens <hauke@openwrt.org>2013-01-06 16:21:29 +0000
commit71830c60f7dbf02b8be097ddfc942e01dc4fb0e4 (patch)
treec8f83b7a719fb7d168480afea6939577d79af1ff /package/kernel
parent009b82e8ef3dedb2ff0534e2219f5b137a5da2b6 (diff)
downloadmaster-187ad058-71830c60f7dbf02b8be097ddfc942e01dc4fb0e4.tar.gz
master-187ad058-71830c60f7dbf02b8be097ddfc942e01dc4fb0e4.tar.bz2
master-187ad058-71830c60f7dbf02b8be097ddfc942e01dc4fb0e4.zip
zram: add package to use compressed ram disk for swap
The busybox size is increased by 3.2KByte uncompressed on bcm47xx with this commit. This zram-swap automatically creates a zram device, a swap partition on it and make the kernel swap pages to it. Thank you Bastian Bittorf <bittorf@bluebottle.com> for idea and the script. git-svn-id: svn://svn.openwrt.org/openwrt/trunk@35025 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/modules/other.mk21
1 files changed, 21 insertions, 0 deletions
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index ddaef8d901..5d3e00a87f 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -747,3 +747,24 @@ define KernelPackage/ikconfig/description
endef
$(eval $(call KernelPackage,ikconfig))
+
+
+define KernelPackage/zram
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=ZRAM
+ DEPENDS:=@!LINUX_3_3 +kmod-lib-lzo
+ KCONFIG:= \
+ CONFIG_ZSMALLOC \
+ CONFIG_ZRAM \
+ CONFIG_ZRAM_DEBUG=n
+ FILES:= \
+ $(LINUX_DIR)/drivers/staging/zsmalloc/zsmalloc.ko \
+ $(LINUX_DIR)/drivers/staging/zram/zram.ko
+ AUTOLOAD:=$(call AutoLoad,20,zsmalloc zram)
+endef
+
+define KernelPackage/zram/description
+ Compressed RAM block device support
+endef
+
+$(eval $(call KernelPackage,zram))