aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-07-14 07:35:45 +0000
committerJohn Crispin <blogic@openwrt.org>2015-07-14 07:35:45 +0000
commit5a388923b5f90ac65d50aedf5df2da9970e36175 (patch)
treeadd6546d0b28a45c9459ab122a2949f003f977e8 /package/kernel
parent02c108076e3985b999b815aa5e9c6236c4f2fa16 (diff)
downloadmaster-187ad058-5a388923b5f90ac65d50aedf5df2da9970e36175.tar.gz
master-187ad058-5a388923b5f90ac65d50aedf5df2da9970e36175.tar.bz2
master-187ad058-5a388923b5f90ac65d50aedf5df2da9970e36175.zip
mac80211: make ath10k firmware v2 selectable
Added option for old firmware version (10.1 API v2). It seems that recent firmware versions are constantly crashing (at least on a QCA9880-BR4A-R) and this provides the option to select an older version instead. Signed-off-by: Günther Kelleter <guenther.kelleter@devolo.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46340 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/mac80211/Makefile19
1 files changed, 19 insertions, 0 deletions
diff --git a/package/kernel/mac80211/Makefile b/package/kernel/mac80211/Makefile
index 7f698f039c..cc98fb7d48 100644
--- a/package/kernel/mac80211/Makefile
+++ b/package/kernel/mac80211/Makefile
@@ -620,6 +620,19 @@ Atheros IEEE 802.11ac family of chipsets. For now only
PCI is supported.
endef
+define KernelPackage/ath10k/config
+ if PACKAGE_kmod-ath10k
+
+ config ATH10K_API2_FW
+ bool "Firmware optimized for AP operation (v10.1 / API v2)"
+ default n
+ help
+ Use the ath10k firmware from the 10.1 SDK using API v2 optimized
+ for access point operation if the default firmware keeps crashing.
+
+ endif
+endef
+
define KernelPackage/carl9170
$(call KernelPackage/mac80211/Default)
TITLE:=Driver for Atheros AR9170 USB sticks
@@ -1844,9 +1857,15 @@ define KernelPackage/ath10k/install
$(INSTALL_DATA) \
$(PKG_BUILD_DIR)/$(PKG_ATH10K_LINUX_FIRMWARE_SUBDIR)/ath10k/QCA988X/hw2.0/board.bin \
$(1)/lib/firmware/ath10k/QCA988X/hw2.0/
+ifeq ($(CONFIG_ATH10K_API2_FW),y)
+ $(INSTALL_DATA) \
+ $(PKG_BUILD_DIR)/$(PKG_ATH10K_LINUX_FIRMWARE_SUBDIR)/10.1/firmware-2.bin_10.1.467.2-1 \
+ $(1)/lib/firmware/ath10k/QCA988X/hw2.0/firmware-2.bin
+else
$(INSTALL_DATA) \
$(PKG_BUILD_DIR)/$(PKG_ATH10K_LINUX_FIRMWARE_SUBDIR)/10.2.4/untested/firmware-5.bin_10.2.4.70-2 \
$(1)/lib/firmware/ath10k/QCA988X/hw2.0/firmware-5.bin
+endif
endef
define KernelPackage/mwl8k/install