aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2013-05-02 11:25:18 +0000
committerJo-Philipp Wich <jow@openwrt.org>2013-05-02 11:25:18 +0000
commit0dc51913793eaa39afa59ae34a6c354972b32113 (patch)
treeb43dd466181287fadb9e0962bd005f62bd8f69bf /package/kernel
parent255d06ab354c8d1a7d0088245752358ffd3929f6 (diff)
downloadmaster-187ad058-0dc51913793eaa39afa59ae34a6c354972b32113.tar.gz
master-187ad058-0dc51913793eaa39afa59ae34a6c354972b32113.tar.bz2
master-187ad058-0dc51913793eaa39afa59ae34a6c354972b32113.zip
kernel: netfilter.mk: Explicitly set the order of autoloaded modules
In my machine, the file is created with arptable_filter before arp_tables. This can't happen because the former depends on the latter. So, instead of rely on wildcards (*.ko), set by hand the files to be loaded in the correct order. Signed-off-by: Jonh Wendell <jonh.wendell@oiwifi.com.br> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36512 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/modules/netfilter.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/kernel/modules/netfilter.mk b/package/kernel/modules/netfilter.mk
index 50180a5f2c..4e4c85f45c 100644
--- a/package/kernel/modules/netfilter.mk
+++ b/package/kernel/modules/netfilter.mk
@@ -402,7 +402,7 @@ endef
$(eval $(call KernelPackage,ip6tables))
-
+ARP_MODULES = arp_tables arpt_mangle arptable_filter
define KernelPackage/arptables
SUBMENU:=$(NF_MENU)
TITLE:=ARP firewalling modules
@@ -410,7 +410,7 @@ define KernelPackage/arptables
KCONFIG:=CONFIG_IP_NF_ARPTABLES \
CONFIG_IP_NF_ARPFILTER \
CONFIG_IP_NF_ARP_MANGLE
- AUTOLOAD:=$(call AutoLoad,49,$(notdir $(patsubst %.ko,%,$(wildcard $(LINUX_DIR)/net/ipv4/netfilter/arp*.ko))))
+ AUTOLOAD:=$(call AutoLoad,49,$(ARP_MODULES))
endef
define KernelPackage/arptables/description