aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/mt76
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-05-08 21:46:42 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-05-08 21:46:42 +0000
commitf054425db33bd6c4714ae7d9265bfa11bd95ec06 (patch)
treeb4d663b6c4d2cb93a0d9a2f8d7d9445289706178 /package/kernel/mt76
parenta1f1d6d251519b981e4e3d5559441b3f3874d77a (diff)
downloadmaster-187ad058-f054425db33bd6c4714ae7d9265bfa11bd95ec06.tar.gz
master-187ad058-f054425db33bd6c4714ae7d9265bfa11bd95ec06.tar.bz2
master-187ad058-f054425db33bd6c4714ae7d9265bfa11bd95ec06.zip
mt76: include generated mac80211 config file and add an appropriate define for mesh support (fixes #19474)
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45649 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/mt76')
-rw-r--r--package/kernel/mt76/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/package/kernel/mt76/Makefile b/package/kernel/mt76/Makefile
index 31cd1208cb..561f6069b2 100644
--- a/package/kernel/mt76/Makefile
+++ b/package/kernel/mt76/Makefile
@@ -33,8 +33,13 @@ NOSTDINC_FLAGS = \
-I$(STAGING_DIR)/usr/include/mac80211-backport \
-I$(STAGING_DIR)/usr/include/mac80211/uapi \
-I$(STAGING_DIR)/usr/include/mac80211 \
+ -include backport/autoconf.h \
-include backport/backport.h
+ifdef CONFIG_PACKAGE_MAC80211_MESH
+ NOSTDINC_FLAGS += -DCONFIG_MAC80211_MESH
+endif
+
define Build/Compile
+$(MAKE) $(PKG_JOBS) -C "$(LINUX_DIR)" \
ARCH="$(LINUX_KARCH)" \