aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/modules
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2007-10-07 17:17:04 +0000
committerGabor Juhos <juhosg@openwrt.org>2007-10-07 17:17:04 +0000
commit6958bdb20aad8a3d1dda124747529f79eec4ce7f (patch)
treeb157c9ce75f7e761524af78499e7fa6b51287758 /package/kernel/modules
parent8853b87bdaec3392e45ec2964f9248334638edce (diff)
downloadmaster-187ad058-6958bdb20aad8a3d1dda124747529f79eec4ce7f.tar.gz
master-187ad058-6958bdb20aad8a3d1dda124747529f79eec4ce7f.tar.bz2
master-187ad058-6958bdb20aad8a3d1dda124747529f79eec4ce7f.zip
add TARPIT support to netfilter/iptables
* netfilter: add the xt_TARPIT target module required by xt_CHAOS * include/netfilter.mk: reorder, xt_CHAOS depends on xt_TARPIT and xt_DELUDE * iptables: add libipt_TARPIT to the kmod-ipt-extra package, bump release number * original patchset can be found [http://tinyurl.com/2mjk2kx here] git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9178 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/modules')
-rw-r--r--package/kernel/modules/netfilter.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/package/kernel/modules/netfilter.mk b/package/kernel/modules/netfilter.mk
index d25296bec0..7813eef395 100644
--- a/package/kernel/modules/netfilter.mk
+++ b/package/kernel/modules/netfilter.mk
@@ -250,6 +250,9 @@ define KernelPackage/ipt-extra/description
- ipt_recent
- iptable_raw
- xt_NOTRACK
+ - xt_TARPIT
+ - xt_DELUDE
+ - xt_CHAOS
endef
$(eval $(call KernelPackage,ipt-extra))