aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/modules
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2007-10-09 19:23:22 +0000
committerGabor Juhos <juhosg@openwrt.org>2007-10-09 19:23:22 +0000
commit199c2d1ca587fe11dce11747a77237c4dff7df72 (patch)
tree2dae4b4fe8dd063109cc4cef7dcd5263045a0a0a /package/kernel/modules
parent6c533f0b92c7f57ab4764f80a6e1f20cc5c377ec (diff)
downloadmaster-187ad058-199c2d1ca587fe11dce11747a77237c4dff7df72.tar.gz
master-187ad058-199c2d1ca587fe11dce11747a77237c4dff7df72.tar.bz2
master-187ad058-199c2d1ca587fe11dce11747a77237c4dff7df72.zip
[adm5120] add custom GPIO-based I2C driver
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9218 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/modules')
-rw-r--r--package/kernel/modules/i2c.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/package/kernel/modules/i2c.mk b/package/kernel/modules/i2c.mk
index 2a41ab3bca..c02672f439 100644
--- a/package/kernel/modules/i2c.mk
+++ b/package/kernel/modules/i2c.mk
@@ -93,6 +93,22 @@ endef
$(eval $(call KernelPackage,i2c-gpio))
+define KernelPackage/i2c-gpio-custom
+ SUBMENU:=$(I2C_MENU)
+ TITLE:=Custom GPIO-based I2C device
+ DEPENDS:=@TARGET_adm5120 kmod-i2c-core +kmod-i2c-gpio
+ KCONFIG:=CONFIG_I2C_GPIO_CUSTOM
+ FILES:=$(LINUX_DIR)/drivers/i2c/busses/i2c-gpio-custom.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:=$(call AutoLoad,58,i2c-gpio-custom)
+endef
+
+define KernelPackage/i2c-gpio-custom/description
+ Kernel module for register a custom i2c-gpio platform device.
+endef
+
+$(eval $(call KernelPackage,i2c-gpio-custom))
+
+
define KernelPackage/i2c-scx200
SUBMENU:=$(I2C_MENU)
TITLE:=Geode SCx200 I2C using GPIO pins