aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/modules/usb.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-05-27 12:33:55 +0000
committerFelix Fietkau <nbd@openwrt.org>2012-05-27 12:33:55 +0000
commitcb7839b1f600d0c78e1974c194e5933480f3ab63 (patch)
treeabf989d306d39736d921038716ebcb79ee37674a /package/kernel/modules/usb.mk
parent1c0a92e465eb324505cb4f4b0b45f608f6dd4746 (diff)
downloadmaster-187ad058-cb7839b1f600d0c78e1974c194e5933480f3ab63.tar.gz
master-187ad058-cb7839b1f600d0c78e1974c194e5933480f3ab63.tar.bz2
master-187ad058-cb7839b1f600d0c78e1974c194e5933480f3ab63.zip
kernel: remove a few more obsolete CompareKernelPatchVer calls, add dependencies on @TARGET_x86 for a few network drivers that are typically not found in non-PC equipment
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@31870 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/modules/usb.mk')
-rw-r--r--package/kernel/modules/usb.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/modules/usb.mk b/package/kernel/modules/usb.mk
index 893d7b2a3f..537149c36d 100644
--- a/package/kernel/modules/usb.mk
+++ b/package/kernel/modules/usb.mk
@@ -16,7 +16,7 @@ define KernelPackage/usb-core
TITLE:=Support for USB
DEPENDS:=@USB_SUPPORT
KCONFIG:=CONFIG_USB CONFIG_XPS_USB_HCD_XILINX=n CONFIG_USB_FHCI_HCD=n
- ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.2)),1)
+ ifndef CONFIG_LINUX_3_1
FILES:= \
$(LINUX_DIR)/drivers/usb/core/usbcore.ko \
$(LINUX_DIR)/drivers/usb/usb-common.ko