aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/modules/usb.mk
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2010-04-23 04:08:26 +0000
committerNicolas Thill <nico@openwrt.org>2010-04-23 04:08:26 +0000
commit4492d796c8dd9da79e8e0044e5c3d29a83b84727 (patch)
treefca0c9083664f5bd877f51ddbab26088c89ce632 /package/kernel/modules/usb.mk
parent2d8b1229c2073d81c9c2eefafd193c1852fed789 (diff)
downloadmaster-187ad058-4492d796c8dd9da79e8e0044e5c3d29a83b84727.tar.gz
master-187ad058-4492d796c8dd9da79e8e0044e5c3d29a83b84727.tar.bz2
master-187ad058-4492d796c8dd9da79e8e0044e5c3d29a83b84727.zip
package/kernel: use macros for kmod-rfkill depends
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@21102 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/modules/usb.mk')
-rw-r--r--package/kernel/modules/usb.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/kernel/modules/usb.mk b/package/kernel/modules/usb.mk
index a5244d6d33..02c6ba8892 100644
--- a/package/kernel/modules/usb.mk
+++ b/package/kernel/modules/usb.mk
@@ -690,12 +690,13 @@ $(eval $(call KernelPackage,usb-net-asix))
define KernelPackage/usb-net-hso
-$(call KernelPackage/usb-net/Depends,@LINUX_2_6 +!TARGET_rb532||!TARGET_avr32||!TARGET_brcm47xx||!TARGET_s3c24xx||!TARGET_ifxmips||!TARGET_atheros||!TARGET_adm5120||!TARGET_ar7||!TARGET_ppc40x||!TARGET_ixp4xx||!TARGET_rdc:kmod-rfkill)
+$(call KernelPackage/usb-net/Depends,@LINUX_2_6)
TITLE:=Kernel module for Option USB High Speed Mobile Devices
KCONFIG:=CONFIG_USB_HSO
FILES:= \
$(LINUX_DIR)/drivers/$(USBNET_DIR)/hso.$(LINUX_KMOD_SUFFIX)
AUTOLOAD:=$(call AutoLoad,61,hso)
+ $(call AddDepends/rfkill)
endef
define KernelPackage/usb-net-hso/description