aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/modules/crypto.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2011-02-12 23:54:59 +0000
committerFelix Fietkau <nbd@openwrt.org>2011-02-12 23:54:59 +0000
commit9d0c3ce03efa41a470dc91a5dc5136db89fd1d31 (patch)
tree8c220813afbb14e35a0321820cd01d4da99c9034 /package/kernel/modules/crypto.mk
parentfb6aa538a557818297381db5477ba04e00375755 (diff)
downloadmaster-187ad058-9d0c3ce03efa41a470dc91a5dc5136db89fd1d31.tar.gz
master-187ad058-9d0c3ce03efa41a470dc91a5dc5136db89fd1d31.tar.bz2
master-187ad058-9d0c3ce03efa41a470dc91a5dc5136db89fd1d31.zip
move the deflate crypto module out of the crypto core and into a separate package - it is only used for ipsec
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@25491 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/modules/crypto.mk')
-rw-r--r--package/kernel/modules/crypto.mk13
1 files changed, 11 insertions, 2 deletions
diff --git a/package/kernel/modules/crypto.mk b/package/kernel/modules/crypto.mk
index 5cf3b0d3b6..4600c67b33 100644
--- a/package/kernel/modules/crypto.mk
+++ b/package/kernel/modules/crypto.mk
@@ -29,8 +29,7 @@ CRYPTO_MODULES = \
HASH2=crypto_hash \
MANAGER2=cryptomgr \
CBC=cbc \
- ECB=ecb \
- DEFLATE=deflate
+ ECB=ecb
crypto_confvar=CONFIG_CRYPTO_$(word 1,$(subst =,$(space),$(1)))
crypto_file=$(if $(findstring y,$($(call crypto_confvar,$(1)))),,$(LINUX_DIR)/crypto/$(word 2,$(subst =,$(space),$(1))).ko)
@@ -183,6 +182,16 @@ endef
$(eval $(call KernelPackage,crypto-des))
+define KernelPackage/crypto-deflate
+ TITLE:=Deflate compression CryptoAPI module
+ KCONFIG:=CONFIG_CRYPTO_DEFLATE
+ FILES:=$(LINUX_DIR)/crypto/deflate.ko
+ AUTOLOAD:=$(call AutoLoad,09,deflate)
+ $(call AddDepends/crypto)
+endef
+
+$(eval $(call KernelPackage,crypto-deflate))
+
define KernelPackage/crypto-hmac
TITLE:=HMAC digest CryptoAPI module