aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/modules/block.mk
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2010-04-29 10:25:57 +0000
committerNicolas Thill <nico@openwrt.org>2010-04-29 10:25:57 +0000
commit0a512ce142d076578a7d67ddaaee5af341c6754a (patch)
treeb97fb446cc610fef26749a04d72211bbcf247b20 /package/kernel/modules/block.mk
parent824fd6af2642f310ea4ab2d4f5cb915b9cb3e52c (diff)
downloadmaster-187ad058-0a512ce142d076578a7d67ddaaee5af341c6754a.tar.gz
master-187ad058-0a512ce142d076578a7d67ddaaee5af341c6754a.tar.bz2
master-187ad058-0a512ce142d076578a7d67ddaaee5af341c6754a.zip
package/kernel: mark a bunch of kmod packages that don't exist on 2.4 as 2.6 only
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@21251 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/modules/block.mk')
-rw-r--r--package/kernel/modules/block.mk5
1 files changed, 4 insertions, 1 deletions
diff --git a/package/kernel/modules/block.mk b/package/kernel/modules/block.mk
index 6ffda26f88..8a4c68a882 100644
--- a/package/kernel/modules/block.mk
+++ b/package/kernel/modules/block.mk
@@ -10,6 +10,7 @@ BLOCK_MENU:=Block Devices
define KernelPackage/aoe
SUBMENU:=$(BLOCK_MENU)
TITLE:=ATA over Ethernet support
+ DEPENDS:=@LINUX_2_6
KCONFIG:=CONFIG_ATA_OVER_ETH
FILES:=$(LINUX_DIR)/drivers/block/aoe/aoe.$(LINUX_KMOD_SUFFIX)
AUTOLOAD:=$(call AutoLoad,30,aoe)
@@ -164,6 +165,7 @@ $(eval $(call KernelPackage,ata-via-sata))
define KernelPackage/block2mtd
SUBMENU:=$(BLOCK_MENU)
TITLE:=Block device MTD emulation
+ DEPENDS:=@LINUX_2_6
KCONFIG:=CONFIG_MTD_BLOCK2MTD
FILES:=$(LINUX_DIR)/drivers/mtd/devices/block2mtd.$(LINUX_KMOD_SUFFIX)
endef
@@ -174,6 +176,7 @@ $(eval $(call KernelPackage,block2mtd))
define KernelPackage/dm
SUBMENU:=$(BLOCK_MENU)
TITLE:=Device Mapper
+ DEPENDS:=@LINUX_2_6
# All the "=n" are unnecessary, they're only there
# to stop the config from asking the question.
# MIRROR is M because I've needed it for pvmove.
@@ -334,7 +337,7 @@ $(eval $(call KernelPackage,ide-pdc202xx))
define KernelPackage/ide-it821x
TITLE:=ITE IT821x IDE driver
- DEPENDS:=@PCI_SUPPORT
+ DEPENDS:=@LINUX_2_6 @PCI_SUPPORT
KCONFIG:=CONFIG_BLK_DEV_IT821X
FILES=$(LINUX_DIR)/drivers/ide/it821x.$(LINUX_KMOD_SUFFIX)
AUTOLOAD:=$(call AutoLoad,30,it821x,1)