aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/mac80211
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2015-03-20 12:13:11 +0000
committerImre Kaloz <kaloz@openwrt.org>2015-03-20 12:13:11 +0000
commita8d8e2b2509bcc2270b9a530afc518f4d55291b5 (patch)
treefcae103cd09106fccd50fa7349df687e564c0630 /package/kernel/mac80211
parent7d1a6c7dfab1997c4276152088ca4a2c19fb3818 (diff)
downloadmaster-187ad058-a8d8e2b2509bcc2270b9a530afc518f4d55291b5.tar.gz
master-187ad058-a8d8e2b2509bcc2270b9a530afc518f4d55291b5.tar.bz2
master-187ad058-a8d8e2b2509bcc2270b9a530afc518f4d55291b5.zip
mac80211: fix 5ghz variable name
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44907 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/mac80211')
-rw-r--r--package/kernel/mac80211/Makefile2
-rw-r--r--package/kernel/mac80211/files/lib/wifi/mac80211.sh4
2 files changed, 3 insertions, 3 deletions
diff --git a/package/kernel/mac80211/Makefile b/package/kernel/mac80211/Makefile
index d71417ec35..c7d7c1e76f 100644
--- a/package/kernel/mac80211/Makefile
+++ b/package/kernel/mac80211/Makefile
@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=mac80211
PKG_VERSION:=2015-03-09
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources
PKG_BACKPORT_VERSION:=
PKG_MD5SUM:=6d4b04e4ce8a1f54dabfb04f4709453c
diff --git a/package/kernel/mac80211/files/lib/wifi/mac80211.sh b/package/kernel/mac80211/files/lib/wifi/mac80211.sh
index ff0d467ab1..ea229d6c03 100644
--- a/package/kernel/mac80211/files/lib/wifi/mac80211.sh
+++ b/package/kernel/mac80211/files/lib/wifi/mac80211.sh
@@ -86,8 +86,8 @@ detect_mac80211() {
iw phy "$dev" info | grep -q '2412 MHz' || { mode_band="a"; channel="36"; }
vht_cap=$(iw phy "$dev" info | grep -c 'VHT Capabilities')
- 5ghz_cap=$(iw phy "$dev" info | grep -c "Band 2")
- [ "$vht_cap" -gt 0 -a "$5ghz_cap" -gt 0 ] && {
+ cap_5ghz=$(iw phy "$dev" info | grep -c "Band 2")
+ [ "$vht_cap" -gt 0 -a "$cap_5ghz" -gt 0 ] && {
mode_band="a";
channel="36"
htmode="VHT80"