aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/mac80211
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2015-06-26 00:43:03 +0000
committerNicolas Thill <nico@openwrt.org>2015-06-26 00:43:03 +0000
commit9cae3d7acae97b3c56d7a56598c588ef9b99338d (patch)
treed996117555741cef66d4b4f29eabfe61c816287f /package/kernel/mac80211
parent7a91070356c1fe41e89fb00fa4854f1e5e69a3df (diff)
downloadmaster-187ad058-9cae3d7acae97b3c56d7a56598c588ef9b99338d.tar.gz
master-187ad058-9cae3d7acae97b3c56d7a56598c588ef9b99338d.tar.bz2
master-187ad058-9cae3d7acae97b3c56d7a56598c588ef9b99338d.zip
mac80211: fix build on UML
A duplicate include guard prevents inclusion of barrier.h in UML build and this prevents mac80211 from building. This patch re-enables mac80211 hwsim and renames the include guard. See https://lists.openwrt.org/pipermail/openwrt-devel/2015-June/033614.html for details. Signed-off-by: Martin Tippmann <martin.tippmann@gmail.com> Signed-off-by: Nicolas Thill <nico@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46133 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/mac80211')
-rw-r--r--package/kernel/mac80211/Makefile2
-rw-r--r--package/kernel/mac80211/patches/010-fix-uml-build.patch15
2 files changed, 16 insertions, 1 deletions
diff --git a/package/kernel/mac80211/Makefile b/package/kernel/mac80211/Makefile
index 344fbd80c5..be26348a13 100644
--- a/package/kernel/mac80211/Makefile
+++ b/package/kernel/mac80211/Makefile
@@ -60,7 +60,7 @@ define KernelPackage/mac80211/Default
SUBMENU:=$(WMENU)
URL:=https://wireless.wiki.kernel.org/
MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
- DEPENDS:=@!TARGET_uml @!LINUX_4_1
+ DEPENDS:=@!LINUX_4_1
endef
define KernelPackage/cfg80211
diff --git a/package/kernel/mac80211/patches/010-fix-uml-build.patch b/package/kernel/mac80211/patches/010-fix-uml-build.patch
new file mode 100644
index 0000000000..0d53e0811e
--- /dev/null
+++ b/package/kernel/mac80211/patches/010-fix-uml-build.patch
@@ -0,0 +1,15 @@
+--- a/backport-include/asm/barrier.h
++++ b/backport-include/asm/barrier.h
+@@ -1,9 +1,9 @@
+-#ifndef __BACKPORT_ASM_GENERIC_BARRIER_H
+-#define __BACKPORT_ASM_GENERIC_BARRIER_H
++#ifndef __BACKPORT_ASM_BARRIER_H
++#define __BACKPORT_ASM_BARRIER_H
+ #include_next <asm/barrier.h>
+
+ #ifndef dma_rmb
+ #define dma_rmb() rmb()
+ #endif
+
+-#endif /* __BACKPORT_ASM_GENERIC_BARRIER_H */
++#endif /* __BACKPORT_ASM_BARRIER_H */