aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/mac80211
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2016-03-23 12:52:24 +0000
committerJohn Crispin <blogic@openwrt.org>2016-03-23 12:52:24 +0000
commit64ce76ec36e8d02fecc09abfc0fb6116505dfc08 (patch)
treee83cdb9f3eb074b05765343f4da490918542b208 /package/kernel/mac80211
parentfac4cfb95f1723e1e87a7b284af2cec4fa870adc (diff)
downloadmaster-187ad058-64ce76ec36e8d02fecc09abfc0fb6116505dfc08.tar.gz
master-187ad058-64ce76ec36e8d02fecc09abfc0fb6116505dfc08.tar.bz2
master-187ad058-64ce76ec36e8d02fecc09abfc0fb6116505dfc08.zip
mac80211: build airo on x86 only
airo requires ISA_DMA_API and that symbol is only set on some ppc,malta,x86 x86 is probably only platform where that driver is used fixes buildbot errors on ar71xx,lantiq ...: airo.ko is missing Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@49073 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/mac80211')
-rw-r--r--package/kernel/mac80211/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/mac80211/Makefile b/package/kernel/mac80211/Makefile
index 734b6fe749..4ab3899133 100644
--- a/package/kernel/mac80211/Makefile
+++ b/package/kernel/mac80211/Makefile
@@ -142,7 +142,7 @@ endef
define KernelPackage/airo
$(call KernelPackage/mac80211/Default)
TITLE:=Cisco Aironet driver
- DEPENDS+=@PCI_SUPPORT +@DRIVER_WEXT_SUPPORT +kmod-cfg80211
+ DEPENDS+=@PCI_SUPPORT +@DRIVER_WEXT_SUPPORT +kmod-cfg80211 @TARGET_x86
FILES:=$(PKG_BUILD_DIR)/drivers/net/wireless/cisco/airo.ko
AUTOLOAD:=$(call AutoProbe,airo)
endef