aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/mac80211
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2016-03-20 14:41:41 +0000
committerJohn Crispin <blogic@openwrt.org>2016-03-20 14:41:41 +0000
commit2e99f6ae82f9c470cf7730df215eb191a5f25b94 (patch)
tree1e718a6cb4ba9a21dd0fd8e9557b91508f12cbd2 /package/kernel/mac80211
parent3e24eb1371448d0cdaa5d284e4c1914abd9217bd (diff)
downloadmaster-187ad058-2e99f6ae82f9c470cf7730df215eb191a5f25b94.tar.gz
master-187ad058-2e99f6ae82f9c470cf7730df215eb191a5f25b94.tar.bz2
master-187ad058-2e99f6ae82f9c470cf7730df215eb191a5f25b94.zip
mac80211: add cisco airo
airo depends on cfg80211, move it to mac80211 Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@49047 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/mac80211')
-rw-r--r--package/kernel/mac80211/Makefile17
1 files changed, 17 insertions, 0 deletions
diff --git a/package/kernel/mac80211/Makefile b/package/kernel/mac80211/Makefile
index e168efd1ac..734b6fe749 100644
--- a/package/kernel/mac80211/Makefile
+++ b/package/kernel/mac80211/Makefile
@@ -24,6 +24,7 @@ PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
PKG_DRIVERS = \
adm8211 \
+ airo \
ath ath5k ath9k ath9k-common ath9k-htc ath10k \
b43 b43legacy \
carl9170 \
@@ -138,6 +139,18 @@ define KernelPackage/adm8211
AUTOLOAD:=$(call AutoProbe,adm8211)
endef
+define KernelPackage/airo
+ $(call KernelPackage/mac80211/Default)
+ TITLE:=Cisco Aironet driver
+ DEPENDS+=@PCI_SUPPORT +@DRIVER_WEXT_SUPPORT +kmod-cfg80211
+ FILES:=$(PKG_BUILD_DIR)/drivers/net/wireless/cisco/airo.ko
+ AUTOLOAD:=$(call AutoProbe,airo)
+endef
+
+define KernelPackage/airo/description
+ Kernel support for Cisco Aironet cards
+endef
+
define KernelPackage/ath/config
if PACKAGE_kmod-ath
config ATH_USER_REGD
@@ -1454,6 +1467,7 @@ config-y:= \
WLAN_VENDOR_ATH \
WLAN_VENDOR_ATMEL \
WLAN_VENDOR_BROADCOM \
+ WLAN_VENDOR_CISCO \
WLAN_VENDOR_INTEL \
WLAN_VENDOR_INTERSIL \
WLAN_VENDOR_MARVELL \
@@ -1492,6 +1506,8 @@ endif
config-$(call config_package,lib80211) += LIB80211 LIB80211_CRYPT_WEP LIB80211_CRYPT_CCMP LIB80211_CRYPT_TKIP
+config-$(call config_package,airo) += AIRO
+
config-$(call config_package,ath) += ATH_CARDS ATH_COMMON
config-$(CONFIG_PACKAGE_ATH_DEBUG) += ATH_DEBUG ATH10K_DEBUG
config-$(CONFIG_PACKAGE_ATH_DFS) += ATH9K_DFS_CERTIFIED ATH10K_DFS_CERTIFIED
@@ -1765,6 +1781,7 @@ endef
$(eval $(call KernelPackage,adm8211))
+$(eval $(call KernelPackage,airo))
$(eval $(call KernelPackage,ath))
$(eval $(call KernelPackage,ath10k))
$(eval $(call KernelPackage,ath5k))