aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/mac80211/Makefile
diff options
context:
space:
mode:
authorRafał Miłecki <zajec5@gmail.com>2015-02-16 19:11:38 +0000
committerRafał Miłecki <zajec5@gmail.com>2015-02-16 19:11:38 +0000
commit6bd910c91b6347f3001e6809c5a5a0416b302105 (patch)
tree49190a9fd3a051b3ff67d9785090842d6a16e501 /package/kernel/mac80211/Makefile
parent786b97003a7aa2277ee5ceea8f9933ec57aea75a (diff)
downloadmaster-187ad058-6bd910c91b6347f3001e6809c5a5a0416b302105.tar.gz
master-187ad058-6bd910c91b6347f3001e6809c5a5a0416b302105.tar.bz2
master-187ad058-6bd910c91b6347f3001e6809c5a5a0416b302105.zip
mac80211: brcmfmac: Add SDIO support option
This patch adds SDIO support for the brcmfmac driver. For now only very few boards need it. Signed off by: José Vázquez Fernández <ppvazquezfer@gmail.com> Signed-off-by: Rafał Miłecki <zajec5@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44465 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/mac80211/Makefile')
-rw-r--r--package/kernel/mac80211/Makefile16
1 files changed, 16 insertions, 0 deletions
diff --git a/package/kernel/mac80211/Makefile b/package/kernel/mac80211/Makefile
index 814eb1cf6d..4ea2f3dc91 100644
--- a/package/kernel/mac80211/Makefile
+++ b/package/kernel/mac80211/Makefile
@@ -1488,6 +1488,21 @@ define KernelPackage/brcmfmac/description
Kernel module for Broadcom IEEE802.11n USB Wireless cards
endef
+define KernelPackage/brcmfmac/config
+ if PACKAGE_kmod-brcmfmac
+
+ config BRCMFMAC_SDIO
+ bool "Enable SDIO support"
+ default n
+ help
+ Enable support for cards attached to an SDIO bus.
+ Select this option only if you are sure that your
+ board has a Broadcom wireless chip atacched to
+ that bus.
+
+ endif
+endef
+
config_package=$(if $(CONFIG_PACKAGE_kmod-$(1)),m)
config-y:= \
@@ -1558,6 +1573,7 @@ config-y += B43LEGACY_DMA_MODE
config-$(call config_package,brcmutil) += BRCMUTIL
config-$(call config_package,brcmsmac) += BRCMSMAC
config-$(call config_package,brcmfmac) += BRCMFMAC
+config-$(CONFIG_BRCMFMAC_SDIO) += BRCMFMAC_SDIO
config-y += BRCMFMAC_USB
config-$(CONFIG_PACKAGE_BRCM80211_DEBUG) += BRCMDBG