aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/mac80211/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-12-05 09:51:35 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-12-05 09:51:35 +0000
commit63470a8656a245c73b04004bd784c5e5176b1aac (patch)
tree3df05c3cd813a92c3b8503614abcae3bac80e617 /package/kernel/mac80211/Makefile
parentaab8a8a71f378d846b0939c80d9c253ecd0e8704 (diff)
downloadmaster-187ad058-63470a8656a245c73b04004bd784c5e5176b1aac.tar.gz
master-187ad058-63470a8656a245c73b04004bd784c5e5176b1aac.tar.bz2
master-187ad058-63470a8656a245c73b04004bd784c5e5176b1aac.zip
mac80211: Allow enabling tracing for the drivers that support it
Signed-off-by: Martin Blumenstingl <martin.blumenstingl@googlemail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47776 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/mac80211/Makefile')
-rw-r--r--package/kernel/mac80211/Makefile19
1 files changed, 19 insertions, 0 deletions
diff --git a/package/kernel/mac80211/Makefile b/package/kernel/mac80211/Makefile
index 04c916771b..58b8ace598 100644
--- a/package/kernel/mac80211/Makefile
+++ b/package/kernel/mac80211/Makefile
@@ -109,6 +109,15 @@ define KernelPackage/mac80211/config
Select this to see extensive information about
the internal state of mac80211 in debugfs.
+ config PACKAGE_MAC80211_TRACING
+ bool "Enable tracing (mac80211 and supported drivers)"
+ select KERNEL_FTRACE
+ select KERNEL_ENABLE_DEFAULT_TRACERS
+ default n
+ help
+ Select this to enable tracing of mac80211 and
+ related wifi drivers (using trace-cmd).
+
config PACKAGE_MAC80211_MESH
bool "Enable 802.11s mesh support"
default y
@@ -1631,6 +1640,16 @@ ifdef CONFIG_PACKAGE_MAC80211_DEBUGFS
ATH5K_DEBUG
endif
+ifdef CONFIG_PACKAGE_MAC80211_TRACING
+ config-y += \
+ ATH10K_TRACING \
+ ATH6KL_TRACING \
+ ATH_TRACEPOINTS \
+ WIL6210_TRACING \
+ ATH5K_TRACER \
+ IWLWIFI_DEVICE_TRACING
+endif
+
config-$(call config_package,lib80211) += LIB80211 LIB80211_CRYPT_WEP LIB80211_CRYPT_CCMP LIB80211_CRYPT_TKIP
config-$(call config_package,ath) += ATH_CARDS ATH_COMMON